コンテンツのアップロードを許可する

HTTP Post は、RFC 1867 としても知られるインターネット コミュニティに向けて提案されたプロトコルです。このプロトコルによって、コンテンツ プロバイダは HTML フォーム コマンドを使用して、クライアント コンピュータから目的のサーバーに Web コンテンツをアップロードできます。HTTP Post プロトコルは、Microsoft® Web 発行ウィザード、Microsoft® インターネット エクスプローラ 3.02 以降、Netscape Navigator 2.02 以降などのツールに使用されています。

Posting Acceptor は、HTTP Post プロトコルを使用しているコンテンツ プロバイダからコンテンツを受信するための、サーバーベースのツールです。Posting Acceptor は、Web ページのほかに、キャビネット (.cab) ファイルに収められているアクティブ サーバー コンポーネントや Java アプレットも受信します。

Posting Acceptor には、コンテンツのアップロード手順を単純化する機能が用意されています。この機能には、以下のものがあります。

  • Active Server Pages (ASP) ページ。コンテンツ プロバイダが、Web コンテンツのアップロードや、サーバー コンポーネントのインストールおよびアンインストールを行う場合に使用するページです。このページは Microsoft® Site Server Express によって作成されます。
  • PostInfo ファイル。中継サーバーへのアップロードに使用されたプロトコルの種類を、クライアント側のコンテンツ ポスト エンジンである WebPost に通知するファイルです。PostInfo ファイルは、Site Server Express のインストール時にデフォルトのディレクトリに格納されます。セキュリティで保護されたコンテンツを HTTPS を使用して受信する場合、WebPost が PostInfo ファイルを取得できるように、Microsoft® Internet Information Services (IIS) で HTTP と HTTPS の両方を有効に設定します。
  • 再ポスト。コンテンツのポスト情報を次の URL に転送します。再ポストでは、実際にポストされたファイルではなく、完了したポストの種類、ファイルがポストされた場所、ポストされたファイルのサイズなどの、ポストされたファイルに関する情報が転送されます。これらの情報は、サーバーの負荷を監視する場合に役立ちます。
  • 匿名アップロード。Posting Acceptor は、IIS でポスト元とポスト先の仮想ディレクトリに適切なアクセス権が設定されている場合に、匿名のソースからのコンテンツを受け入れます。デフォルトでは、匿名アップロードは無効です。

デフォルトでは、Posting Acceptor はポストを許可する前に認証を要求します。IIS は NTLM 認証だけを使用するように設定されています。Netscape Navigator は 基本認証のみをサポートしています。IIS と Netscape Navigator を併用するためには、次のいずれかを実行します。

  • Posting Acceptor を、匿名アップロードを許可するように設定し直します。「匿名コンテンツのアップロードを許可する」を参照してください。
  • IIS を、基本認証を使用可能にするように設定し直します。IIS のマニュアルを参照してください。
  • Netscape Navigator クライアントを、NTLM をサポートするようにプラグインによって拡張します。Netscape のマニュアルを参照してください。

関連項目

  • Posting Acceptor で WebPost を使用する
  • pasetup.inc ファイルについて
  • Posting Acceptor の Active Server Pages (ASP) を使用する


Posting Acceptor で WebPost を使用する

Posting Acceptor に同梱されている Microsoft® Web 発行ウィザードおよび WebPost API (WPAPI) は、コンテンツの作成者がコンテンツをアップロードするための Active Server Pages (ASP) にアクセスしたときに、クライアント コンピュータにダウンロードできます。

ASP には WPAPI に依存するアップロード コントロールが含まれています。WPAPI は、クライアント側のコンテンツ ポスト エンジンで、コンテンツを Web サーバーにポストします。クライアント コンピュータに WPAIP がインストールされていない場合や、インストールされている WPAIP のバージョンが古い場合は、最新のバージョンが、Web Publishing Wizard と共に自動的にクライアントにダウンロードされます。

Web 発行ウィザードは、ASP を使うことによって、コンテンツをポストするための別の方法を提供します。コンテンツの作成者は、Web 発行ウィザードを使用することによって、個人用 Web ページ、グラフィック ファイル、およびプロジェクト フォルダを Web サーバーに転送する作業を簡単に行えます。Web 発行ウィザードは、プロセスに沿って進み、発行するコンテンツのファイル名、転送先 URL、およびアップロード プロトコル (FTP、HTTP Post、Microsoft® FrontPage® など) の入力を求めます。

Web 発行ウィザードについては、オンライン ヘルプを参照してください。

関連項目

  • コンテンツのアップロードを許可する
  • pasetup.inc について


pasetup.inc ファイルについて

pasetup.inc ファイルは、Posting Acceptor のすべての設定が記載されたインクルード ファイルです。Posting Acceptor の設定は、あらかじめ設定されており、通常は変更する必要がありません。pasetup.inc ファイルは c:\Program Files\Microsoft Site Server Express\SitesServer\Publishing ディレクトリにあります。

pasetup.inc ファイルに記載されている設定の一部を、以下に示します。

  • ターゲット URL。ポストされるコンテンツの宛先。
  • 再ポスト URL。ポストに関する情報の転送先。この情報には、ポストされたファイルのサイズとポスト元を含めることができます。
  • ポスティング URL。Posting Acceptor がインストールされているサーバー上の仮想ディレクトリ。この仮想ディレクトリを変更することはお勧めしません。
  • スキーム。ファイルのアップロード用のセキュリティ設定。デフォルトでは、HTTP に設定されています。セキュリティ認証をインストールしてあり、Secure Sockets Layer (SSL) を使ってファイルのアップロードをセキュリティ保護する場合は、この設定を HTTPS に変更します。
  • 匿名コンテンツの許可。 匿名のソースからポストされたコンテンツを許可するための設定。デフォルト設定は 0 (無効) です。1 以上に設定すると、匿名アップロードが許可されます。この設定を変更する場合は、Allow Anonymous レジストリ キーを適切に変更する必要があります。

pasetup.inc ファイルを編集する場合は、任意のテキスト エディタを使用します。編集が終わったら、変更を反映するために、サーバーの World Wide Web (WWW) サービスを停止してから再起動します。

関連項目

  • 匿名コンテンツのアップロードを許可する


匿名コンテンツのアップロードを許可する

Posting Acceptor は、インストールした時では、匿名コンテンツのアップロードを許可しないように設定されています。匿名のアップロードをサイトで許可することが必要な場合は、以下を確認します。

  • 複製先ディレクトリに、関連する仮想ディレクトリがある。
  • Posting Acceptor がインストールされているスクリプト ディレクトリに対して匿名の接続を許可するように、Microsoft® Internet Information Services (IIS) が設定されている。
  • インターネットのゲスト アカウントに、Posting Acceptor がファイルの保存を試みる複製先ディレクトリに対して書き込み権限がある。
  • ターゲット URL に、仮想ディレクトリ内で書き込み権限がある。

匿名アップロードを有効にするには、pasetup.inc ファイルの Allow Anonymous を 0 (無効) から 1 以上に変更し、Allow Anonymous レジストリ キーも変更する必要があります。

注

pasetup.inc ファイルおよびレジストリ キーを変更するには、Microsoft® Windows NT® サーバーに関する詳しい知識が必要なため、通常はお勧めできません。

Posting Acceptor は、Web サーバーで SSL が有効に設定されている場合、セキュリティで保護されている匿名ポストを許可します。

SSL、および IIS の設定については、IIS のマニュアルを参照してください。

関連項目

  • pasetup.inc ファイルについて


Posting Acceptor の Active Server Pages (ASP) ページを使用する

コンテンツは Active Server Pages (ASP) によってサーバーにポストされます。それらの ASP は、サーバー上の仮想ディレクトリ http://<local server>/scripts にインストールされています。コンテンツをポストすると、ASP コードで指定したターゲット URL が、IIS によってサーバー上の共通のディレクトリにマップされます。ポストされた ASP には、次のページが含まれています。

  • アップロード ページ (http://<local server>/scripts/upload.asp)。コンテンツ プロバイダが、Web コンテンツをアップロードするためのページです。アップロード ページはコンテンツを C:\Program Files\Microsoft Site Server Express\Sites\Publishing\Users ディレクトリに指示します。

    アップロード ページは、使用されているブラウザを検出して、適切なアップロード機能を表示します。たとえば、Microsoft® Internet Explorer を使用している場合は、ActiveX® のアップロード コントロールを使用し、Netscape Navigator を使用している場合は、ファイルをアップロードするダイアログ ボックスを使用します。

  • インストール ページ (http://<local server>/scripts/install.asp) およびアンインストール ページ (http://<local server>/scripts/uninstall.asp)。 コンポーネントのインストール ページは、.cab ファイルに収められているコンポーネントを取り出して、コンポーネントの INF ファイルに指定されているディレクトリにインストールします。アンインストール ページは、希望する .cab ファイルを、指定したサーバーから削除します。

すべての ASP に対するポスト元 URL、インストール先 URL、および アンインストール先 URL のデフォルト設定は、C:\Program Files\Microsoft Site Server Express\SitesServer\Publishing ディレクトリにある pasetup.inc ファイルに記載されています。

注

Posting Acceptor の以前のバージョンをインストールし、そのバージョンで提供されるアップロード ページをカスタマイズした場合、カスタマイズしたアップロード ページは、Microsoft® Site Server Express のインストール時に削除されます。

関連項目

  • アップロード ページを使用してコンテンツをアップロードするには
  • コンポーネント インストール ページを使用してコンポーネントをインストールするには
  • コンポーネント アンインストール ページを使用してコンポーネントをアンインストールするには


アップロード ページを使用してコンテンツをアップロードするには

  1. インターネット ブラウザを開きます。
  2. ブラウザで http://<servername>/scripts/upload.asp に進みます。
  3. 次のいずれかのオプションをクリックします。
    • [ActiveX コントロールを使ってファイルを仮想ディレクトリにアップロードする](Internet Explorer の場合)
    • [HTTP Post (RFC1867) を使ってファイルを仮想ディレクトリにアップロードする](ActiveX をサポートしないブラウザの場合)
  4. ActiveX を使用する場合は、ファイルをアップロード アイコンにドラッグします。HTTP Post を使用する場合は、[参照] をクリックして、アップロードする各ファイルを見つけます。
  5. [アップロード] をクリックします。


コンポーネント インストール ページを使用してコンポーネントをインストールするには

  1. インターネット ブラウザを開きます。
  2. ブラウザで http://<servername>/scripts/install.asp に進みます。
  3. [サーバー側のコンテンツをインストールします] をクリックします。
  4. インストールする .cab ファイルのパス名を入力するか、[参照] をクリックしてそのファイルを見つけます。
  5. [インストール] をクリックします。


コンポーネント アンインストール ページを使用してコンポーネントをアンインストールするには

  1. インターネット ブラウザを開きます。
  2. ブラウザで http://<servername>/scripts/uninstall.asp に進みます。
  3. [サーバー側のコンテンツをアンインストールします] をクリックします。
  4. アンインストールする .cab ファイルのパス名を入力するか、[参照] をクリックしてそのファイルを見つけます。
  5. [アンインストール] をクリックします。


トランザクション設定について

Posting Acceptor のトランザクションについて

Posting Acceptor には、次の 2 つのデフォルトのトランザクション設定があります。これらの設定は、レジストリで指定されています。

  • トランザクション タイムアウト。ポストを試行する時間を分単位で指定します。指定された時間内にコンテンツがポストされなかった場合は、トランザクションがキャンセルされます。デフォルトは 10 分間です。これは、WebPost (Microsoft® Web 発行ウィザードなど) を使用してファイルをアップロードするクライアントのためのオプションです。WebPost は、アップロード中に切断して再接続できる唯一のポスト エンジンです。
  • 最大同時トランザクション数。同時に試行できるポスト数を指定します。デフォルトは 200 です。これは、接続クライアント数と各トランザクションの処理速度のバランスが適切になる数字です。

これらの設定は、Transaction Timeout と Maximum Concurrent Transactions レジストリ キーで変更することができますが、レジストリ キーは変更しないようにすることをお勧めします。


Usage Import

Usage Import では、サイトに関する利用状況データが入ったログ ファイルを Microsoft® Site Server Express Analysis データベースにインポートできます。Usage Import はこのインポート処理にロジックを適用し、サイトの訪問アクティビティについてのデータを再構築します。インポートが終了したら、Report Writer を開始してデータに関するレポートを実行できます。ログ ファイルを正しくインポートするには、その前に Usage Import を設定する必要があります。ここでは、データのインポート方法を、制御およびカスタマイズするためのオプションについて説明します。

  • インポートの対象となるデータについて
  • Usage Import に必要な最少の操作
  • ログ ファイルのインポート
  • インポート プロセスの管理
  • インポート済みのログ ファイルを管理する

Usage Import を設定したら、ログ ファイルがインポートできます。インポート済みのログ ファイルや要求の削除にも Usage Import を使用します。

Usage Import の設定と管理には、次のツールを使用します。

  • サーバー マネージャ。 ログ ファイルをインポートできるように Usage Import を設定するための基本ツールです。
  • インポート マネージャ。ログ ファイルをインポートするときに使用するツールです。
  • インポート履歴マネージャ。 インポート済みのログ ファイルや要求を削除するときに使用するツールです。

インポート マネージャやインポート履歴マネージャでは、スケジューラを使用して、さまざまな作業を自動化することもできます。

注意

Usage Import を終了してから、Report Writer を起動し、レポートを実行してください。そうしないと、正確なレポートのデータが生成されない場合があります。

関連項目

  • アクティビティのスケジュール


インポートの対象となるデータについて

データベースにインポートし、レポートの基本として使用できるデータは、次の 5 種類に分類されます。

  • ヒット。 ログ ファイル中の行。ヒットには、コンテンツの要求、エラー、空白行、およびインターネット接続のオーバーヘッドが含まれます。このヒットを使用して、レポートの、ヒット数の要約や帯域幅データが算出されます。
  • 要求。 コンテンツを正常に取得したヒット。要求は、コンテンツやユーザーの動作に関連しています。たとえば、ユーザーが 1 つの HTML ページを要求し、そのページに 3 つのグラフィック ファイルが入っているとします。Web サーバーは、ログ エントリを 1 つ作成し、その中に HTML ページと 3 つのグラフィック ファイルに関する情報を書き込みます。また、オーバーヘッドに関する行が追加されることもあります。ただし、Analysis がカウントする要求は、1 つだけです。
  • 訪問。 ユーザーが出す一連の要求。訪問を始めるには、2 とおりの方法があります。1 つは、ユーザーがリンクを介してサイトを参照する方法です。もう 1 つは、ユーザーがサイトの URL をブラウザに入力する方法です。サイトへの要求が一定時間 (デフォルトは 30 分) ないと、訪問は終了したことになります。
  • ユーザー。 サイトにアクセスするホスト名 (たとえば、example.microsoft.com) と関連付けられたエンティティ (使用者またはインターネット ゲートウェイ)。ユーザーがインターネット ゲートウェイの場合は、サイトを実際に訪問した人数より少ない数がユーザーとして記録されることがあります。Usage Import では、ユーザーを認識する方法として cookie を使用することをお勧めします。cookie は、ユーザーのハード ディスクに割り当てられます。cookie がある場合、cookie はユーザーを識別するためのデータとして維持および使用され、ユーザーの来訪の記録が可能になります。cookie がない場合、Usage Import は登録ユーザー名を使用します。登録ユーザー名がない場合は、ホスト名を使用します。
  • 組織。 InterNIC、APNIC、または RIPE NCC に登録されている 1 つまたは複数のインターネット ドメインを持つ、互いに関係し合うユーザーのグループ。代表的な組織には、会社、政府機関、大学、非営利団体などがあります。


Usage Import に必要な最少の操作

次の操作は、Report Writer を起動して利用状況データのレポートを実行する前に、Usage Import で実行する必要がある最低限の操作です。

  1. サイトを追加し、設定する。
  2. ログ データ ソースを変更する (必要な場合)。
  3. ログ データ ソース、サーバー、サイトの名前を変更し、意味のある名前にする。
  4. ログ ファイルをインポートする。
  5. IP アドレスを解決する。
  6. Whois 検索を実行する。
  7. HTML タイトル検索を実行する。
  8. Usage Import を終了し、Report Writer を起動して、レポートを実行する。


Usage Import のインターフェイスを使用する

Usage Import にアクセスするには、次の 2 つのインターフェイスを使用できます。それぞれのインターフェイスには特徴があるので、必要に応じて最適なインターフェイスを選択してください

  • 標準インターフェイス。Usage Import のすべての機能とオプションを管理できます。
  • コマンド ライン インターフェイス。複数のプラットフォームで、コマンド プロンプトから Usage Import の機能をリモート管理できます。

関連項目

  • Usage Import を起動するには


Usage Import を起動するには

  • [スタート] ボタンをクリックし、[プログラム] 、[Microsoft Site Server] の順にポイントします。次に、[Usage Import] をクリックします。


Usage Import と Report Writerの推奨セットアップ

Microsoft® Site Server Express を複数のサーバーにインストールする場合は、Analysis を専用のコンピュータにインストールすることをお勧めします。

Usage Import は、複数の中央演算処理装置 (CPU) を利用できるように設定されているため、CPU を追加することによって、インポートのパフォーマンス全体が自動的に向上します。ただし、向上の程度は、状況によって異なります。

拡張ログ用の Web サーバー自動設定

Usage Import は自動的に Microsoft® 拡張ログ ファイル形式を使用し、Web サーバーの拡張ログのために設定します。この形式は、参照元のデータ、ユーザー エージェントのデータ、および cookies の収集に使用されます。

関連項目

  • ログ ファイル形式のリファレンス ガイド


ログ ファイルをインポートする

Usage Import は、インストール中に、ログ データ ソースとサーバーの設定を自動的に行います。Usage Import をインストール後、ログ ファイルをインポートするには、あらかじめサイトを追加する必要があります。

ログ データ ソース

ログ データ ソースとは、特定の形式のログ ファイルを生成するエンティティを表し、通常は、物理サーバーです。この物理サーバーで生成されるログ ファイルを、サーバー マネージャでログ データ ソースと関連付けます。

注

Usage Import では、複数のログ データ ソースを追加できます。ただし、一度にインポートできるログ データ ソースは 1 つだけです。

サイト訪問者がファイルをダウンロードしたり、ページ間を移動したりすると、ログ ファイルに利用状況データが収集されます。ログ ファイルは特定の形式で生成され、サーバーによって形式が異なります。

ログ ファイルについては、ご使用のサーバーのマニュアルを参照してください。

サーバー

サーバー マネージャで言うサーバーとは、コンテンツを配信し、ユーザーからの要求に応答するソフトウェア プロセスのことです。通常は、コンテンツを配信するソフトウェア プロセスを物理サーバーに 1 つ用意します。サーバー マネージャでは、ログ データ ソースの下にサーバーをセットアップします。

サイト

サーバー マネージャで言うサイトとは、コンテンツの集合体のことです。通常、サーバー マネージャではサイトは、コンテンツで編成されたディレクトリ (たとえば、/thissite/*) やディレクトリの集まり (たとえば、/thissite1/* や /thissite2/*) に対応します。サーバー マネージャのサーバーの下には、1 つのサイトを編成するのが普通です。ただし、コンテンツをカテゴリ別に分類する場合は、1 つのサーバーの下に複数のサイトを編成することもできます。このガイドでは、1 つまたは複数の URL プリフィックスを共有する、グループ化された Web ページを指す場合も、広い意味で "サイト" という用語を使用しています。

次の例は、2 つの物理サーバーでログ ファイルを生成する組織の一般的なサーバー マネージャの設定です。

関連項目

  • 1 つのサーバーの下に複数のサイトをセットアップする
  • ログ ファイル形式のリファレンス ガイド


サイトを追加し、設定する

サイトに関連付けられたデータをインポートするには、その前にサイトを追加し、設定する 必要があります。

サイトを設定する場合は、通常、ホーム ページ URL を指定します。また、サーバー マネージャの 1 つのサーバーの下に複数のサイトをセットアップする場合は、各サイトの URL パス エクステンションを指定します。ホーム ページ URL は、次の目的で指定します。

  • インポート中に、内部および外部の参照元を区別します。
  • HTML レポートでサイトへのリンクを作成するときは、先頭に指定した URL が使用されます。

Usage Importによるログ データ ソースとサーバーのセットアップと、サイトをサーバー マネージャでセットアップの終了後、データのインポート方法を制御し、カスタマイズすることができます。次の表は、各オプションの説明と詳細へのリンクです。

オプション | 説明
データをインポート対象から除外する | データをインポート対象から除外すると、ファイルをインポートするのにかかる時間を短縮できるだけでなく、データベースを小さく保つことができます。また、レポートを実行する時間も短縮できます。
インポート時にイントラネットを識別する | データベース内の、ユーザーからの要求の発生元に関する情報が、さらに詳しくなります。


サイトを追加し、設定するには

Usage Import を始めてインストールする場合は、手順 3. から実行します。

  1. Usage Import を起動し、[表示] メニューの [サーバー マネージャ] をクリックします。
  2. 設定するサイトのあるサーバーをクリックし、[編集] メニューの [新しいサイト] をクリックします。既存のサイトを設定するには、対象のサイトをクリックし、[編集] メニューの [プロパティ] をクリックします。
  3. [基本設定] タブの [ホーム ページ URL (必須)] ボックスに、サイトのホーム ページ URL を入力します。たとえば、「www.microsoft.com」と入力します。サイトに複数のホーム ページ URL がある場合は、「www.microsoft.com」「microsoft.com」など、すべてのホーム ページ URL を入力します。

注

[ホーム ページ URL (必須)] ボックスでプロトコルを含めずに指定した URL には、Usage Import が http:// を付けます。https を使用する場合は、その URL の先頭に「https://」と入力する必要があります。たとえば、「https://www.microsoft.com」と指定します。

  4. サーバーの下に追加して設定するサイトが 1 つだけの場合、または複数のサイトをセットアップしていても、当該サイトをデフォルトのサイトとして設定する場合は、[サイトの URL パスの拡張子 (オプション)] ボックスを空白のままにしておきます。
  5. データベースからの情報を除外する場合は、[除外] タブをクリックし、「データをインポート対象から除外する」を参照します。
  6. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • サイトを追加し、設定する
  • 1 つのサーバーの下に複数のサイトをセットアップする
  • インポート時にイントラネットを識別する


データをインポート対象から除外する

インポート対象から除外できるデータには、ホスト、ディレクトリ、ファイルの種類、およびクローラの 4 つがあります。このオプションは、インポートの対象とするデータを限定するときに使用すると効果的です。データをインポート対象から除外すると、ファイルをインポートするのにかかる時間を短縮できるだけでなく、データベースを小さく保つことができます。また、レポートを実行する時間も短縮できます。

注

除外するホストとファイルの種類は、サイトごとに設定できます。ただし、クローラを除外すると、サーバー マネージャでセットアップしたサイトすべてに適用されます。

ホストを除外する

社員やソフトウェア テスターなど、一定の要求を除外する場合は、ホストをインポート対象から除外できます。通常、このオプションは内部ホストを除外する場合に使用しますが、それ以外の場合でも任意のホストを指定できます。

注

除外するホストと関連付けられた要求はインポートされません。ただし、除外するホスト名と関連付けられたヒットは、ヒット数の要約や帯域幅の計算に使用されます。

ファイルの種類を除外する

ファイルの種類をインポート対象から除外する のは、通常、インライン イメージ (Web ページに埋め込まれたイメージ) を除外する場合です。インライン イメージに対する要求は、データベースにインポートしない場合などに効果的です。インライン イメージを除外しても、ヒット数や帯域幅の計算には影響しません。デフォルトでは、*.gif、*.jpg、*.jpeg、または *.cdf の各拡張子を持つファイルが除外されます。

必要に応じて、ナビゲーション用のページを除外対象のファイルとして指定することで、要求としてカウントされないようにすることができます。

クローラを除外する

クローラをインポート対象から除外すると、インターネット検索エンジン、ロボット、およびその他のユーザー エージェントによるヒットをデータベースにインポートしないようにすることができます。これらのヒットは、レポートのヒット数や帯域幅データにはそのまま使用されます。クローラを除外するために、クローラのデフォルトの一覧が用意されています。通常、この一覧を変更する必要はありません。デフォルトの一覧には、代表的な Web 監査組織で除外されている主要なクローラが含まれています。


ホストをインポート対象から除外するには

  1. Usage Import を起動し、[表示] メニューの [サーバー マネージャ] をクリックします。
  2. 除外するホストがあるサイトをクリックします。[編集] メニューの [プロパティ] をクリックし、[除外] タブをクリックします。
  3. [除外するホスト] ボックスに、インポート対象から除外するホストの IP アドレスとドメイン名を入力します。たとえば、「microsoft.com 10.86.22.*」と入力します。
  4. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • データをインポート対象から除外する


ファイルの種類をインポート対象から除外するには

  1. Usage Import を起動し、[表示] メニューの [サーバー マネージャ] をクリックします。
  2. 除外するファイルの種類のサイトをクリックします。[編集] メニューの [プロパティ] をクリックし、[除外] タブをクリックします。
  3. デフォルトでは、*.gif、*.jpg、*.jpeg、および *.cdf の拡張子を持つファイルが除外されます。除外するファイルの拡張子を追加するには、[除外するファイルの種類] ボックスに拡張子を入力します。このとき、複数の拡張子は、二重引用符とスペースで区切ります。たとえば、「".mfa" ".mft"」と入力します。二重引用符は、エントリが "My file.txt" のようにスペースを含んでいる場合にだけ必要です。
  4. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • データをインポート対象から除外する


クローラをインポート対象から除外するには

この操作を行うと、ユーザーのすべてのサイトのクローラが除外されます。

  1. Usage Import を起動し、[ツール] メニューの [オプション] をクリックし、[クローラ一覧] タブをクリックします。
  2. [クローラを除外する] チェック ボックスをオンにします。
  3. 除外されるデフォルトのクローラを変更するには、[クローラ ユーザー エージェント文字列] ボックスに、インポート対象から除外するクローラのユーザー エージェント文字列を入力します。各クローラの名前は引用符で囲み、複数のクローラは、スペースで区切ります。
  4. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • データをインポート対象から除外する


インポート時にイントラネットを識別する

サイトが大規模または複雑な場合は (たとえば、いくつものサブドメインがある大規模なイントラネットなど)、ドメインのツリー構造で組織を定義することもできます。このように定義すると、データベース内の、ユーザーからの要求の発生元に関する情報が、さらに詳しくなります。また、インポート時にイントラネットを識別する場合にも便利です。デフォルトでは、ドメインは部分に分けられていません。このため、インポートされるのは、インターネット ドメイン (たとえば、microsoft.com) だけです。設定できるドメインの最大数は 2 つです。次の表は、設定に応じてデータベースにインポートされる情報の例です。

設定 | データベースにインポートされる情報の例
インターネットの組織以外のドメイン部分はない (デフォルト設定)。 | microsoft.com
インターネットの組織以外のドメイン部分が 1 つある。 | ca.microsoft.com ny.microsoft.com
インターネットの組織以外のドメイン部分が 2 つある。 | marketing.ca.microsoft.com engineering.ca.microsoft.com marketing.ny.microsoft.com engineering.ny.microsoft.com


インポート時にイントラネットを識別するには

  1. Usage Import を起動します。
  2. [ツール] メニューの [オプション] をクリックし、[イントラネット] タブをクリックします。
  3. デフォルト設定ではドメイン部分はありません。[インターネット組織名を超えて解析するサブ ドメイン名の数] ボックスに 0 ～ 2 の値を入力して、解析の対象とするドメイン部分の数を指定できます。
  4. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • インポート時にイントラネットを識別する


1 つのサーバーの下に複数のサイトをセットアップする

サーバー マネージャでは、1 つのサーバーの下に複数のサイトをセットアップできます。これは、コンテンツをカテゴリ別に分け、カテゴリごとにデータを区別する場合に便利です。これによって、カテゴリごとにデータが区別されたレポートが実行できます。この場合は、サイトのすべてのコンテンツを 1 つのディレクトリ (たとえば、/thissite/*) または複数のディレクトリ (たとえば、/thissite1/* と /thissite2/*) に入れてから、サーバー マネージャで 1 つのサーバーの下のすべてのサイトをセットアップします。

サーバーの下に複数のサイトをセットアップする場合は、サーバー マネージャを設定するための一般情報として、「ログ データ ソースを変更する」、および「サーバーの設定」、および「サイトを追加し、設定する」も参照してください。

サーバーの下に複数のサイトをセットアップするときは、サイトのプロパティのダイアログ ボックスの [サイトの URL パスの拡張子 (オプション)] ボックスで、サイトのコンテンツがあるディレクトリを指定します。ディレクトリを指定することによって、ログ ファイル中の要求すべてが特定のサイトに関連付けられます。たとえば、サイトのコンテンツすべてが 1 つのパス上にある場合は、「/thissite/*」などと入力します。コンテンツが複数のディレクトリに入っている場合は、/filepath1/* and /filepath2/* の形式で入力します。

デフォルトのサイトを設定すると、ほかのサイトで指定されているディレクトリにはないコンテンツの要求がすべて、インポートでデフォルトのサイトに割り当てられます。デフォルトのサイトを設定していないと、指定したパスと一致しない要求はインポートで廃棄されます。サーバーの下でデフォルトのサイトとして設定するには、[サイトの URL パスの拡張子] ボックスを空白のままにしておきます。

次の例は、1 つのサーバーの下に複数のサイトをセットアップした場合のサーバー マネージャです。

この例では、アイコンでわかるように Marketing サイトがデフォルトのサイトです。Marketing、Sales、および Service の各サイトごとにデータを分けたレポートを実行できます。

関連項目

  • サイトを追加し、設定するには
  • サーバーの設定


ログ データ ソースを変更する

Usage Import がログ データ ソースを追加するときに、自動的にログ ファイル形式をログ データ ソースに関連付けます。インポートを開始しすると、ログ ファイル形式が確認されます。ログ ファイルの行がいくつか読み取られ、ログ ファイル形式が判定されます。Usage Import がログ ファイル形式を判定できない場合は、エラー メッセージが表示されます。この場合は、ユーザーがサーバー マネージャでログ ファイル形式を指定する必要があります。

Usage Import が自動的にログ データ ソースをセットアップしたあと、必要に応じてログ データ ソースを追加することができます。

注

Microsoft® Site Server Express の旧バージョンをアップグレードし、Microsoft® 拡張ログ ファイル形式または Microsoft ハイパー拡張ログ ファイル形式のどちらかを使用している場合は、別のログ ファイル形式に変更する必要があります。Microsoft® Internet Information Services (IIS) W3C 拡張ログ ファイル形式を使用することをお勧めします。ログ ファイル形式を変更していないと、データが正しくインポートされない可能性があります。

Microsoft® Site Server Express は前バージョンの Site Server Express からのデータベースを更新することはできません。

関連項目

  • ログ ファイル形式のリファレンス ガイド


ログ データ ソースを変更するには

  1. Usage Import を起動し、[表示] メニューの [サーバー マネージャ] をクリックします。
  2. 変更対象のログ データ ソースを選択し、[編集] メニューの [プロパティ] をクリックします。
  3. ログ データ ソースに該当するログ ファイル形式をクリックし、[OK] をクリックします。

    ログ ファイル形式がわからない場合は、各サイトの Web 管理者に問い合わせてください。

注

Usage Import は、Microsoft® Open Database Connectivity (ODBC) データベースからデータをインポートできます。ODBC データベースからインポートする場合は、Usage Import がログ ファイル形式を自動的に検出します。

関連項目

  • Usage Import を起動するには
  • ログ データ ソースを変更する
  • ODBC データベースからインポートする


サーバーの設定

Usage Import はサーバーに関連付けられたデータがインポートされる前に、自動的にサーバーを追加し設定します。必要に応じて、サーバーを設定するには、サーバーの種類、ディレクトリ インデックス ファイル、IP アドレス、IP ポート、ローカル タイム ゾーン、およびローカル ドメインを指定します。

サーバーの種類

Usage Import はサーバーを追加して設定するときに、ログ データ ソースに関連付けられた適切なサーバーの種類を選択します。

ディレクトリ インデックス ファイル

サイト訪問者がディレクトリを要求したとき (つまり、"/" で終わる要求をしたとき) にサーバーが返すファイルを、設定する対象のサーバーごとに指定します。Usage Import によるインポート処理では、ディレクトリ インデックス ファイルに対する要求はディレクトリに対する要求と見なされます。そのため、同じファイルに対する要求が、ファイルごとに別の要求として数えられることがありません。たとえば、設定で default.htm と指定すると、/default.htm に対する要求も "/" に対する要求もデータベースで "/" として記録されます。物理サーバーに複数のディレクトリ インデックス ファイルが設定されている場合は、各ファイルを指定する必要があります。サーバーに設定されているディレクトリ インデックス ファイルがわからない場合は、Web 管理者に問い合わせてください。

IP アドレスと IP ポート

IP アドレスと IP ポートを指定すると、除外するホストのデフォルトを設定することになります。ホストを除外するように選択すると、サーバーを設定するときに指定した IP アドレスと IP ポートが、自動的に除外するホストの一覧に追加されます。ただし、サーバーを初期セットアップした後で IP アドレスと IP ポートを指定する場合は、除外するホストの一覧に手動で追加する必要があります。

ローカル タイム ゾーン

コンテンツのホストがある物理サーバーのタイム ゾーンを指定します。

注

必要に応じて、要求のタイムスタンプをインポート中に調整できます。たとえば、物理サーバーのホストがニューヨークにあっても、ロスアンジェルス時間でデータを分析できます。

ローカル ドメイン

コンテンツのホストとして使用するハードウェアの、ローカル ネットワークで使用されるドメイン名です。この名前を指定すると、ログ ファイル内の不完全なホスト名を完全に解決できます。ホスト名は、組織内のユーザーがその組織のサイトを訪問する場合に、解決が不十分なままログ ファイルに書き込まれることがあります。指定したローカル ドメインは、インポート中に、解決が不十分なホスト名に付加されます。したがって、完全なホスト名をデータベースにインポートできます。これは、Whois 検索を実行する場合に便利です。ホスト サービスを利用する場合は、そのホスト サービスのドメインを入力します。組織にサイトのホストがある場合は、組織のドメインを入力します。

関連項目

  • データベース中のデータの品質を高める


サーバーを設定するには

  1. Usage Import を起動し、[表示] メニューの [サーバー マネージャ] をクリックします。
  2. 設定するサーバーを選択し、[編集] メニューの [プロパティ] をクリックします。
  3. [サーバーの種類] ボックスの一覧で、追加するサーバーの種類をクリックします。
  4. [ディレクトリ インデックス ファイル] ボックスは、デフォルト設定の default.asp と default.htm になっています。必要に応じて、デフォルト設定をサーバーのディレクトリ インデックス ファイルに変更します。複数のファイルは、二重引用符とスペースで区切ります。たとえば「"file1.htm" "file1.asp"」と入力します。サーバーに設定されているディレクトリ インデックス ファイルがわからない場合は、Web 管理者に問い合わせてください。カンマとスペースがエントリの区切りに使用されている場合は、"My file.txt" のように二重引用符が必要です。スペースがエントリに含まれていない場合は、二重引用符の使用はオプショナルです。サーバーに設定されているディレクトリ インデックス ファイルがわからない場合は、Web 管理者に問い合わせてください。
  5. [IP アドレス (オプション)] ボックスに、Web サーバーの IP アドレスを入力します。入力には 10.15.12.6 の形式を使用します。 通常、[IP ポート] ボックスでデフォルトのポート設定を変更する必要はありません。デフォルト設定は、Web サーバーは 80、FTP サーバーは 23 です。
  6. [ホスト機能] の [ローカル タイムゾーン] ボックスで、物理サーバーのホストがあるタイム ゾーンをクリックします。
  7. [ローカル ドメイン] ボックスにローカル ドメイン名を入力します。ホスト サーバーを使用する場合はそのホスト サーバーのドメイン名を入力します。ホスト以外のサーバーを使用する場合は、ユーザーの組織のドメイン名 (microsoft.com など) を入力します。
  8. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • サーバーの追加および設定


ログ データ ソース、サーバー、サイトの削除または名前変更

サーバー マネージャでログ データ ソース、サーバー、およびサイトを追加した後で、それぞれの名前を変更して、もっとわかりやすくすることもできます。ログ データ ソースの名前を変更すると、新しい名前がインポート マネージャとインポート履歴マネージャで使用されます。サーバーまたはサイトの名前を変更すると、そのサーバーまたはサイトと関連付けられたデータを参照するときに、Microsoft® Site Server Express Analysis 全体で新しい名前が使用されます。たとえば、サイトのデータが入ったレポートでもサイトの新しい名前が使用されます。

必要に応じて、ログ データ ソース、サーバー、またはサイトを削除することもできます。

重要

ログ データ ソースを削除すると、そのログ データ ソースの下にあるサーバーとサイトも削除されます。ログ データ ソースに関連付けられたサーバーやサイトのデータがすべて削除され、回復は不可能です。サイトを削除すると、そのサイトと関連付けられたデータがすべて削除され、回復は不可能です。


ログ データ ソース、サーバー、またはサイトの名前を変更するには

  1. Usage Import を起動し、[表示] メニューの [サーバー マネージャ] をクリックします。
  2. 名前を変更するログ データ ソース、サーバー、またはサイトをクリックし、新しい名前を入力します。
  3. Enter キーを押します。

関連項目

  • Usage Import を起動するには


ログ データ ソースまたはサイトを削除するには

  1. Usage Import を起動し、[表示] メニューの [サーバー マネージャ] をクリックします。
  2. 削除するログ データ ソース、またはサイトをクリックします。[編集] メニューの [削除] をクリックします。
  3. [はい] をクリックして確認します。

注

サーバーを追加したり削除したりすることはできません。

関連項目

  • Usage Import の起動


インポート プロセスを管理する

ログ ファイルをインポートするように Usage Import を設定すると、インポート マネージャを使用してログ ファイルをインポートできます。初回のインポートを始める前にログ ファイルのデフォルト ディレクトリを指定すると、ログ ファイルを簡単に見つけることができます。

サーバーがログを Microsoft® オープン データベース コネクティビティ (ODBC) データベースに記録する場合はODBC データベースからインポートできます。

注

Usage Import は、ZIP 形式 (バージョン 1.1 以降) および GZIP 形式 (バージョン 4.1 以降) で圧縮済みのログ ファイルをインポートできます。また、ZIP のアーカイブでは、Usage Import によって、ログを処理する正しい手順が自動的に判断されます。ログ ファイルを圧縮するときに、高速圧縮オプションは使用しないでください。Usage Importによってログ ファイルをインポートできなくなる可能性があります。

インポートを実行した後に、インポートの統計が [Usage Import 統計] ウィンドウに表示されます。この統計を参照すると、個々の計算の所要時間がわかります。

関連項目

  • インポート統計を解釈する


ログ ファイルのデフォルト ディレクトリを指定する

インポートの手順を簡素化するために、ログ ファイルが入ったディレクトリを、デフォルト ディレクトリとして指定しておくことができます。こうすると、ログ ファイルを簡単に見つけることができます。デフォルト ディレクトリを指定することによって、ログ ファイルに対する操作を次のように簡素化できます。

  • インポート マネージャで [参照] をクリックすると、Usage Import によって自動的にデフォルト ディレクトリが表示されます。
  • インポート マネージャの [説明] ボックスに、ディレクトリのフル パスを入力する必要がなくなります。ログ ファイル名を入力するだけで済みます。
  • ディレクトリを指定しなくても、コマンド行操作を実行できます。

注

デフォルト ディレクトリのローカル パスを指定する必要があります。


デフォルト ディレクトリを指定するには

  1. Usage Import を起動します。
  2. [ツール] メニューの [オプション] をクリックし、[ログ ディレクトリ] タブをクリックします。
  3. [ログ ファイル] ボックスにデフォルト ディレクトリのフル パスを入力するか、[参照] をクリックしてディレクトリを指定します。
  4. [OK] をクリックします。

関連項目

  • ログ ファイルのデフォルト ディレクトリを指定する
  • Usage Import を起動するには


ログ ファイルをインポートする

FTP サーバーからログ ファイルをインポートするときは、単一のログ ファイルをインポートすることも、ログ データ ソースから複数のログ ファイルを一度にインポートすることもできます。複数のログ ファイルをインポートしても、データベースにインポートされるデータに影響はありません。複数のログ ファイルを一度にインポートした場合は、インポート履歴マネージャに 1 行で記録されます。この行をダブルクリックすると、インポートしたすべてのログ ファイルが [インポート履歴の詳細] ウィンドウに表示されます。

ローカル エリア ネットワーク (LAN) 上のプロキシ サーバーを介してインターネットに接続している場合は、FTP サーバーからログ ファイルをインポートする前に、FTP プロキシ サーバーとポートを指定する必要があります。


FTP サーバーからログ ファイルをインポートするには

  1. Usage Import を起動し、[表示] メニューの [インポート マネージャ] をクリックします。
  2. [新規インポート] の下の [ログ データ ソース] ボックスで、FTP サーバーが関連付けられているログ データ ソースをクリックします。
  3. [プロトコル] ボックスの一覧で、[ftp://] をクリックし、[ログイン] をクリックします。

    [FTP URL プロパティ] ダイアログ ボックスが表示されます。

  4. [ホスト名] ボックスに、FTP サーバーのホスト名を入力します。
  5. [ユーザー名] ボックスに、ユーザー名を入力し、[パスワード] ボックスに、パスワードを入力します。
  6. [ファイル名 (フル パス) が必要です。)] ボックスに、ログ ファイルのパスとファイル名を入力し、[OK] をクリックします。
  7. [追加] をクリックします。

    ホスト名、ユーザー名、およびパスワードが同じログ ファイルは、手順 4. から 7. を繰り返し、1 度でインポートできます。

  8. [開始] をクリックします。

関連項目

  • Usage Import を起動するには
  • ODBC データベースからインポートする


ODBC データベースからインポートする

サーバーがログを ODBC データベースに記録する場合は、ODBC データベースからデータをインポートします。

注

ODBC データベースからインポートする前に、データ ソース名 (DSN) を定義しておく必要があります。

関連項目

  • ODBC システム データ ソースを設定するには


ODBC データベースからインポートするには

  1. Usage Import を起動し、[表示] メニューの [インポート マネージャ] をクリックします。
  2. [新規インポート] の下の [ログ データ ソース] ボックスの一覧で、ODBC データベースが関連付けられているログ データ ソースをクリックします。
  3. [アクセス] ボックスの一覧で、[ODBC] をクリックし、[ログイン] をクリックします。

    [ODBC URL プロパティ] ダイアログ ボックスが表示されます。

  4. [ODBC DSN] ボックスに、データ ソース名 (DSN) を入力し、[ログ テーブル] ボックスに、データベースのログが記録されているテーブルの名前を入力します。

    テーブル名を確認するには、データベース管理者に問い合わせるか、各データベース テーブルを開いて、ログ データが入っているテーブルを見つけます。

  5. [ユーザー名] ボックスに、ユーザー名を入力します。必要に応じて、[パスワード] ボックスにパスワードを入力し、[OK] をクリックします。
  6. [追加] をクリックします。

    1 度にインポートできるログ テーブルの数は、1 つのログ データ ソースにつき 1 つだけです。

  7. [開始] をクリックします。

関連項目

  • Usage Import を起動するには


ODBC システム データ ソース名を作成するには

次の手順は、Analysis データベースの ODBC システム データ ソースを設定するために使用します。正式運用システムを設定する場合、サイトのデータベースが複数のコンピュータに分散しているときには、各コンビュータに異なる DSN を設定する必要があります。データベースへのアクセスを制限するために、異なる DSN を設定する場合もあります。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に、[コントロール パネル] をクリックし、[ODBC] アイコンをダブルクリックします。

    [ODBC データ ソース アドミニストレータ] ダイアログ ボックスが表示されます。

  2. [システム DSN] タブをクリックし、[追加] をクリックします。

    [データ ソースの新規作成] ダイアログ ボックスが表示されます。

  3. [SQL Server] を選択し、[完了] をクリックします。

    [SQL Server に接続するための新規データ ソースを作成する] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに、この SQL Server のデータ ソースの名前を入力します。たとえば、Analysis Database などの名前を付けます。
  5. 必要に応じて、[説明] ボックスにデータ ソースの簡単な説明を入力します。
  6. [サーバー] ボックスで、登録した SQL Server の名前を選択し、[次へ] をクリックします。

    次の [SQL Server に接続するための新規データ ソースを作成する] ダイアログ ボックスが表示されます。

  7. [SQL Server が、ログイン ID の権限の確認を行う方法は?] で [ユーザーが入力する SQL Server 用のログイン ID とパスワードを使う] チェック ボックスがオンになっていることを確認します。
  8. [ログイン ID] ボックスと [パスワード] ボックスに、SQL Server を登録したときと同じログイン ID とパスワードを入力します。

    Site Server の初期インストール時には、ID として「SA」を使用し、パスワードは空のままにしてログインできるので、すべてのデータベースに簡単にアクセスできます。SQL Server を設定する際は、セキュリティ上の理由から、別のアカウントおよびパスワードを使用する必要があります。

  9. [次へ] をクリックします。

    次の [SQL Server に接続するための新規データ ソースを作成する] ダイアログ ボックスが表示されます。

  10. [デフォルト データベースを以下のものに変更する] チェック ボックスをオンにし、この DSN に対する Site Server データベースを選択します。たとえば、"SSAnalysis" を選択します。ほかのデフォルト設定を受け入れ、[次へ] をクリックします。

    次の [SQL Server に接続するための新規データ ソースを作成する] ダイアログ ボックスが表示されます。

  11. [SQL Server ODBC ドライバが選択したトランスレータを使用する] チェック ボックスがオンになっていることを確認し、[次へ] をクリックします。

    次の [SQL Server に接続するための新規データ ソースを作成する] ダイアログ ボックスが表示されます。

  12. [完了] をクリックします。

    [ODBC Microsoft SQL Server セットアップ] ダイアログ ボックスが表示され、新しく作成された ODBC システム データ ソースの設定が表示されます。

  13. [データ ソースのテスト] をクリックします。

    [SQL Server ODBC データ ソース テスト] ダイアログ ボックスが表示され、テストが正常に完了したことを示すメッセージが表示されます。

  14. [OK] をクリックします。

    [ODBC Microsoft SQL Server セットアップ] ダイアログ ボックスが表示されます。

  15. [OK] をクリックします。

    [ODBC データ ソース アドミニストレータ] ダイアログ ボックスが表示されます。

  16. SQL データベースごとにデータ ソース名を作成する必要があるので、操作手順 2. から 15. を繰り返し、もう 1 つのデータ ソース名を作成します。
  17. [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。


インポート統計を解釈する

インポートを実行すると [Usage Import 統計] ダイアログ ボックスが表示され、インポートに関する情報を確認できます。

注

必要に応じて、特定のインポート統計を保存できます。この操作を行うには、インポート統計を [Usage Import 統計] ダイアログ ボックスでコピーし、テキスト エディタに貼り付けます。

次の表は、インポート後に [Usage Import 統計] ダイアログ ボックスに表示されるメッセージです。

メッセージ | 説明
<ヒット数> ヒット数の合計。 | ログ ファイルの行数。
<要求数> インポートされた要求。 | インポートされた要求数。
<行数> のヒットを解析できませんでした | 形式が適していないためにインポートされなかった、ログ ファイル中のエントリの数。ヒットがまったくインポートされておらず、解析できないエントリが多くある場合は、サーバー マネージャを正しく設定してあるかどうかを確認する必要があります。
<参照元の数> の見つからない参照元要求が挿入されました。 | 挿入された参照元の数。
<ヒット数> のヒットがクライアントのエラーでした。 | 応答コード 400 があるためにインポートされなかったヒットの数。
<ヒット数> のヒットがサーバーのエラーでした | 応答コード 500 があるためにインポートされなかったヒットの数。
<ヒット数> のヒットがリダイレクトされました。 | 応答コード 300 があるためにインポートされなかったヒットの数。
<ヒット数> のヒットが、正しいインターネットまたはイントラネット プロトコルからのものではありませんでした。 | 一部のログ ファイル形式には、1 つのログ ファイルに複数の種類のサイトからの要求が入っています。要求のサイトの種類が、現在のサイトの種類と一致しない場合は、要求がインポートされません。
<ヒット数> のヒットが、未設定のサーバーに移動しました。 | ログ ファイル中の、サイト ID またはサイト名がサーバー マネージャで設定しているものと一致しない場合は、そのサイトへのヒットが廃棄されます。
<ヒット数> のヒットが、未設定のサーバーに移動しました。 | ログ ファイル中の、サーバー ID またはサーバー名がサーバー マネージャで設定しているものと一致しない場合は、そのサーバーへのヒットが廃棄されます。
<ヒット数> のヒットが、除外されたインライン イメージに移動しました。 | 除外したファイルの種類へのヒット数。「 データをインポート対象から除外する」を参照してください。
<ヒット数> のヒットが、除外されたホストからのものでした。 | 除外したホストへのヒット数。「Excluding Data from Being Imported」を参照してください。
<ヒット数> のヒットが、除外されたスパイダからのものでした。 | 除外したクローラへのヒット数。「 データをインポート対象から除外する」を参照してください。
<ヒット数> のヒットが、要求ではなくアップロードでした。 | FTP ログ ファイルのインポートだけに適用されます。FTP サイトからのダウンロード要求だけがインポートされます。
<オープン訪問数> | オープン訪問数。
<バイト数> バイト送信されました。 | サーバーがクライアントに送信したバイト数。
<バイト数> バイト受信されました。 | クライアントがサーバーに送信したバイト数。


インポート済みのログ ファイルを管理する

インポートしたログ ファイルは、インポート履歴マネージャを使用して管理します。インポート履歴マネージャでは、インポート済みのログ ファイルの表示、インポートの削除、および要求の削除を行えます。インポート履歴マネージャでは情報が列形式で表示されます。列の表示/非表示は切り替えることができます。

列 | 説明
[アクション] | アクション (インポート、削除、中止のいずれか) が一覧表示されます。"削除" は、要求を削除したことを表します。インポート全体を削除すると、インポート履歴マネージャに表示されなくなります。"中止" は、インポートを停止したり、ログ ファイルの重複オプションが [インポートをすべて中止する] に設定されていたり、インポート時にエラーが発生した場合に表示されます
[ログ データ ソース] | ログ ファイルをインポートした最初のログ データ ソースが一覧表示されます。
[説明] | アクションに応じて、最初にインポートしたログ ファイル名、または要求を削除するために使用したフィルタが一覧表示されます。
[インポート サイズ (MB]) | インポートしたログ ファイルの合計サイズが一覧表示されます (インポート全体)。
[要求] | アクションに応じて、インポートした要求の数、または削除した要求の数が一覧表示されます。
[開始時間] | アクションを開始した時刻が一覧表示されます。
[継続時間] | アクションにかかった時間が一覧表示されます。
[ユーザー] | アクションを実行したユーザーが一覧表示されます。

注

複数のログ ファイルを一度にインポートすると、インポート履歴マネージャで 1 行に記録されます。その行をダブルクリックすると、[インポート履歴の詳細] ダイアログ ボックスが表示され、まとめてインポートしたログ ファイルを確認できます。

インポートを削除する

データベースのサイズを削減したり、古いデータを削除するために、インポートを削除できます。インポートを削除すると、インポートされたすべてのデータがデータベースから削除されます。削除したデータをデータベースに戻す方法は、ログ ファイルをもう一度インポートすることだけです。

要求を削除する

ログ ファイル全体を削除するのでなく、選択した要求だけを削除できます。要求を削除するときは、フィルタを使用して削除対象の要求を指定します。フィルタは、名前と値を組み合わせたブール式です。基本フィルタは、名前、演算子、および値から構成され、<フィルタ名><演算子><値> の構文で指定します。要求を削除するときに指定できるフィルタ名は、時間のプロパティ (日付、曜日、週、月、四半期、および年) とサイトのプロパティ (サイト、サーバー、およびログ データ ソース) です。


インポート履歴マネージャの列の表示/非表示を切り替えるには

  1. Usage Import を起動し、[表示] メニューの [インポート履歴マネージャ] をクリックします。
  2. [表示] メニューの [カラム] をポイントし、表示する列のタイトルをクリックします。

    インポート履歴マネージャで列が既に表示されている場合は、列名の横にチェック マークが表示されます。チェック マークがついた列名をクリックすると、その列はインポート履歴マネージャで非表示になります。

  3. インポート履歴マネージャに表示する各列に対して、手順 2. を繰り返します。

関連項目

  • Usage Import を起動するには
  • インポート済みのログ ファイルを管理する


インポートを削除するには

  1. Usage Import を起動し、[表示] メニューの [インポート履歴マネージャ] をクリックします。
  2. 削除するインポートがある行の左の灰色のセルをクリックします
  3. [編集] メニューの [削除] をクリックします。
  4. 削除を確認するメッセージが表示されたら、[はい] をクリックします。
  5. 削除内容を示すダイアログボックスが表示されたら [OK] をクリックします。

注

インポートを削除すると、インポートされたすべてのデータがデータベースから削除されます。削除したデータをデータベースに戻す方法は、ログ ファイルをもう一度インポートすることだけです。

関連項目

  • Usage Import を起動するには
  • インポート済みのログ ファイを管理する


要求を削除するには

  1. Usage Import を起動し、[表示] メニューの [インポート履歴マネージャ] をクリックします。
  2. [編集] メニューの [要求の削除] をクリックします。
  3. [現在のフィルタの新しい式を作成します] の下の [ディメンジョン] ボックスで、フィルタ処理に使用するディメンジョンを入力するか、一覧でクリックします。
  4. [条件] ボックスの一覧で、演算子をクリックします。
  5. [値] ボックスで、フィルタ処理に使用する値を入力するか、一覧でクリックします。
  6. [追加] をクリックします。

    [ブール式フィルタを一致する要求を削除する] ボックスにフィルタが表示されます。たとえば、(日付 < "1/1/97") というフィルタを追加すると、1997 年 1 月 1 日より前の要求を削除できます。

  7. [削除] をクリックします。 メッセージが表示されたら、[はい] をクリックして確認します。削除内容を示すダイアログボックスが表示されたら [OK] をクリックします。

注

同じフィルタを何度も使用する場合は、反転表示してコピーし、貼り付けることができます。

関連項目

  • Usage Import を起動するには
  • インポート済みのログ ファイルを管理する


データベース中のデータの品質を高める

インターネット プロトコル (IP) アドレス解決、Whois 検索、および HTML タイトル検索の 3 つは、データベース中のデータの品質をより高くするための手段です。これらを使用すると、レポートがわかりやすいものになります。IP アドレス解決、Whois 検索、およびHTML タイトル検索は、ログ ファイルをデータベースにインポートした後で実行します。また、これらをインポート後に自動的に実行するように設定することもできます。

注

ローカル エリア ネットワーク (LAN) 上のプロキシ サーバーを介してインターネットに接続している場合は、IP アドレス解決、Whois 検索、および HTML タイトル検索を実行する前に、インターネットに接続する方法を指定する必要があります。

IP アドレス解決

IP アドレスを解決すると、ログ ファイルにあった IP アドレスがデータベースではドメイン名に変換されます。IP アドレス解決は、DNS 反転とも呼ばれます。たとえば、198.105.232.4 は microsoft.com に変換されます。この IP アドレス解決では、通常、データベース中の IP アドレスの 60 ～ 75 % が解決されます。

Usage Import は、マルチスレッドの IP アドレス解決をサポートしています。つまり、一定数の IP アドレスをまとめて解決できます。これによって、Usage Import での DNS サーバーの処理が最適化されます。

Whois 検索

Whois 検索を実行すると、IP アドレス解決で変換されたデータベース中のドメイン名が解釈され、組織名などが抽出されます。正確な検索結果を得るためには、Whois 検索を実行する前には、IP アドレスを解決しておく必要があります。

注

アメリカのドメインに対して Whois 検索を実行しても、一部のホスト名の郵便番号は返されないことがあります。このような場合、郵便番号が得られないドメイン名のデータは、"組織所在地の郵便番号"、"組織所在地の市町村"、または "組織所在地の都道府県" をディメンジョンとして含む計算には入れられません。

HTML タイトル検索

HTML タイトル検索は、データベース中の HTML タイトル タグがあるすべてのファイルに、タイトルを関連付けます。レポートには意味のあるタイトルが付けられるので、内容が理解しやすくなります。HTML タイトル検索を実行すると、Usage Import は、サイトからファイルを要求し、そのファイルの <TITLE> テキストを解析します。HTML タイトル検索にかかる時間は、ファイルの数とインターネット接続の速度によって決まります。

HTML 検索にフィルタを使用すると、目的に合わせて検索を柔軟に行えます。デフォルトは (タイトル = "") です。このフィルタを使用すると、データベース内のタイトルのないエントリがすべて抽出されます。HTML タイトルを変更した場合は、(タイトル = "*") のフィルタを使用して HTML タイトル検索を実行できます。このフィルタでは、Usage Import はすべての HTML ファイルを参照して、古いタイトルを新しいタイトルに置き換えます。

注

ドキュメントのタイトルがアポストロフィを含む場合は、HTML タイトル検索はできません。


IP アドレスを解決するには

IP アドレスを解決する前に、DNS サーバーのドメインを指定してください。

  1. Usage Import を起動し、[ツール] メニューの [IP アドレスの解決] をクリックします。
  2. [OK] をクリックして IP アドレスの解決を開始します。
  3. IP 解決が終了すると、解決にかかった時間と成功率を示すウィンドウが表示されます。
  4. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • データベース中のデータの品質を高める


Whois 検索を実行するには

正確な検索結果を得るには、Whois 検索を実行する前に、IP アドレスを解決してください。

  1. Usage Import を起動し、[ツール] メニューの [Whois 検索] をクリックします。
  2. [OK] をクリックして Whois 検索を開始します。
  3. 検索が終了すると、検索にかかった時間と成功率を示すウィンドウが表示されます。
  4. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • データベース中のデータの品質を高める


HTML タイトル検索を実行するには

  1. Usage Import を起動し、[ツール] メニューの [HTML タイトルの検索] をクリックします。
  2. 必要に応じて、デフォルトのフィルタ (タイトル = "") を別のフィルタに変更します。たとえば、データベース内のタイトルすべてを更新するには、「タイトル = "*"」と入力します。
  3. [検索] をクリックして HTML タイトル検索を開始します。
  4. 検索が終了すると、検索にかかった時間と成功率を示すウィンドウが表示されます。
  5. [OK] をクリックします。

注

ドキュメントのタイトルがアポストロフィを含む場合は、HTML タイトル検索はできません。

関連項目

  • Usage Import を起動するには
  • データベース中のデータの品質を高める


インターネットに接続する

ローカル エリア ネットワーク (LAN) 上のプロキシ サーバーを介してインターネットに接続している場合に、IP アドレス解決、Whois 検索、HTML タイトル検索、または FTP インポートを実行するときは、インターネットにアクセスする方法を指定する必要があります。

HTML タイトル検索を実行するには、HTTP プロキシ サーバーとポートを指定する必要があります。

FTP サーバーからログ ファイルをインポートするには、FTP プロキシ サーバーとポートを指定する必要があります。

IP アドレス解決を実行する場合は、DNS サーバーのドメインを指定して、IP アドレス解決の正確度を向上させなければなりません。DNS サーバーをホスト サービスで動作させている場合は、ホスト サービスの DNS サーバーのドメインを指定します。また、IP アドレス解決を実行してもアドレスがまったく解決されない場合は、ネットワーク管理者に伝送制御プロトコル (TCP) トラフィックをポート 53 にするように依頼してください。

Whois 検索を何度実行しても結果が返されない場合は、ネットワーク管理者に TCP トラフィックをポート 43 にするように依頼してください

関連項目

  • データベース中のデータの品質を高める


HTTP プロキシ サーバーとポートを指定するには

  1. Usage Import を起動します。
  2. [ツール] メニューの [オプション] をクリックし、[サーバー] タブをクリックします。
  3. [HTTP プロキシ] ボックスに、HTTP プロキシ サーバーのアドレスを入力します。プロキシ サーバーでユーザー名とパスワードが必要な場合は、プロキシ ホスト名を password@hostname の構文で入力します。
  4. [HTTP ポート] ボックスに、HTTP プロキシ サーバーのポート番号を入力します。
  5. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • インターネットに接続する


FTP プロキシ サーバーとポートを指定するには

  1. Usage Import を起動します。
  2. [ツール] メニューの [オプション] をクリックし、[サーバー] タブをクリックします。
  3. [FTP プロキシ] ボックスに、FTP プロキシ サーバーのアドレスを入力します。
  4. [FTP ポート] ボックスに、FTP プロキシ サーバーのポート番号を入力します。
  5. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • インターネットに接続する


DNS サーバーのドメインを指定するには

  1. Usage Import を起動します。
  2. [ツール] メニューの [オプション] をクリックし、[サーバーの設定] タブをクリックします。
  3. [DNS サーバーのローカル ドメイン] ボックスに、組織の DNS サーバーのドメインを入力します。ホスト サービスを利用している場合は、ホスト サービスの DNS サーバーのドメインを指定します。たとえば、「microsoft.com」と入力します。
  4. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • インターネットに接続する


ログ ファイル形式のリファレンス ガイド

Usage Import がログ ファイルを正しく解釈するためには、ログ ファイルが次の表に示すいずれかの形式である必要があります。ログ ファイルの詳細については、サーバーのマニュアルを参照してください

注

Usage Import がログ ファイル形式を自動的に検出するように設定することができます。したがって、このリファレンス ガイドはあくまでも参考用およびトラブルシューティング用です。

サポートされているログ ファイル形式 (収集されるデータの例を見るには、目的のログ ファイル形式のリンクをクリックしてください。)
Microsoft IIS W3C 拡張ログ ファイル形式
Microsoft IIS NCSA 共通ログ ファイル形式
Microsoft IIS ログ ファイル形式
Microsoft Netshow ログ ファイル形式

注意

Usage Import が正しく認識するためには、ログ ファイルが上の表のいずれかのログ ファイル形式であることが必要です。


Microsoft IIS W3C 拡張ログ ファイル形式

Microsoft® IIS W3C 拡張ログ ファイル形式で収集されるデータは変更可能です。したがって、収集対象のデータを制御することができます。この形式は、Web サーバーおよび FTP サーバーと互換性があります。

次は、この形式のメタ記述および収集された情報の例です。

#Version: 1.0
#Date: 07-Aug-1998
#Fields: time cs-method cs-uri
00:34:23 GET /products/clamp.html


Microsoft IIS ログ ファイル形式

このログ ファイル形式では、IIS の下で動作する Web、Gopher、および FTP サーバーに関する利用状況情報が収集されます。この形式は、Web サーバーおよび FTP サーバーと互換性があります。次は、この形式の例です。

www.microsoft.com, -, 8/7/98, 8:54:39, W3SVC, WWW,157.54.17.9, 490, 232, 4401, 200, 0,GET, /analyst/, -,


Microsoft IIS NCSA 共通ログ ファイル形式

このログ ファイル形式では、インターネット アドレス、ユーザー名、タイムスタンプ、ファイル名、およびファイル サイズが収集されます。次は、この形式の例です。

www.microsoft.com - bob [07/Aug/1998:06:00:00 -0800] "GET /analyst/HTTP/1.0" 200 1067

注

Usage Import では、ログ ファイル行中のファイル サイズの後に続くテキストすべてが無視されます。


Microsoft Netshow ログ ファイル形式

このログ ファイルは、Microsoft® Netshow からデータをインポートするときに使用します。詳細については、Netshow のマニュアルを参照してください。


Report Writer

Report Writer を使用すると、サイトの利用状況のレポートが実行できます。ユーザーの訪問に見られる傾向、人気のあるページ、ユーザーがサイト内をどのように移動しているか、およびユーザーがどこからアクセスしているかを知ることができます。たとえば、組織要約レポートを実行すると、"このサイトへの訪問数が多い上位 15 の組織はどこか" という情報が得られます。Report Writer には、実行するだけで情報を収集できる標準レポート定義が 約 30 用意されています。また、標準レポート定義をカスタマイズすることができます。

注意

Report Writer を起動してレポートを実行する場合は、あらかじめ Usage Import を閉じておく必要があります。Usage Import を閉じないでレポートを実行すると、レポートのデータが正しくない場合があります。

関連項目

  • レポート定義の要素について
  • 標準レポート リファレンス ガイド


Report Writer インターフェイスを使用する

Report Writer にアクセスするには、次の 2 つのインターフェイスを使用できます。それぞれのインターフェイスには特徴があるので、必要に応じて選択してください。

  • 標準インターフェイス。Report Writer のすべての機能とオプションが使用できます。
  • コマンド ライン インターフェイス。複数のプラットフォームで、MS-DOS プロンプトから Report Writer をリモート管理できます。

関連項目

  • Report Writerを起動する


Report Writer を起動するには

  • [スタート] メニューで、[プログラム] 、[Microsoft Site Server Express] の順にポイントし、[Report Writer] をクリックします。


レポート定義の要素について

各レポートには構造を示すレポート定義があります。ルートのレベルで、レポート定義の要素 ("セクション"、"計算"、"ディメンジョン"、"メジャー"、"フィルタ"、および "プレゼンテーション") は、追加、削除、または変更できます。各レポート定義はレポート定義ファイルに対応しています。レポート定義ファイルは、通常、.mfa という拡張子で Catalog ディレクトリに保存されます。

レポート定義を表示してレポートを実行する前に、レポートの構造およびレポートに含まれる情報を決定できます。次のレポート定義のサンプルは、レポート定義内の要素がどのように表示されるかを示しています。

レポート定義の基本的な要素は、セクション、計算、ディメンジョン、メジャー、およびプレゼンテーションです。これらの要素には階層的な関係があります。セクションには計算が含まれ、計算にはディメンジョン、メジャー、およびプレゼンテーションが含まれます。

  • セクション。レポート定義内では、ロート形のアイコンで示されます。各レポートには、少なくとも 1 つの "ルート" セクションがあり、常にレポート定義の一番上に表示されます。レポートのほかのセクションは、ルート セクションの従属セクションとなります。セクションは主に計算のコンテナ、および計算を分類する手段として機能します。
  • 計算。レポート定義内では電卓のアイコンで示されます。計算は主にディメンジョン、メジャー、およびプレゼンテーションのコンテナとして機能します。計算は 1 つ以上のメジャーで構成され、任意の数のディメンジョンが含まれます。1 つの計算は通常 1 つのプレゼンテーションに対応しますが、1 つの計算に対して複数のプレゼンテーションを使用することもできます。
  • ディメンジョン。通常、結果をテーブルまたはグラフでグループ化するためのデータとして機能します。ディメンジョンには任意の数の値を関連付けできます。たとえば、ディメンジョン "年" には、"ヒット数"、"ユーザー数"、"参照組織数" など、多くのメジャーを関連付けできます。
  • メジャー。計算で実際にカウントされる値です。メジャーには 1 つだけ値を関連付けできます。たとえば、メジャー "訪問数" は単一の値を表します。
  • プレゼンテーション。テーブルまたはグラフです。データを異なる形式で表示する場合は、計算に対して複数のプレゼンテーションを使用できます。プレゼンテーションの形式を変更するために、数多くのオプションがあります。

次の図は、ディメンジョンやメジャーが、グラフやテーブルでどのように表示されるかを示しています。

関連項目

  • レポート定義を表示するには
  • レポートの形式を指定する
  • ディメンジョンおよびメジャーについて


レポート定義の要素の名前の変更、要素の削除、または要素の移動

セクション、計算、ディメンジョン、またはメジャーの名前を変更できます。使用する名前はレポートに表示されるので、組織に固有の用語を使用できます。レポート定義からセクション、計算、ディメンジョン、またはメジャーを削除できます。これは、レポートの一部だけを表示し、レポートの実行に必要な時間を短縮する場合に便利です。レポートに表示される順序を変更する場合は、セクション、計算、ディメンジョン、またはメジャーを移動できます。また、レポート定義内またはほかのレポート定義との間で、要素の切り取り、コピー、および貼り付けもできます。

重要

標準レポートのレポート定義の要素を変更する場合は、[レポート定義に名前を付けて保存] コマンドでこのレポート定義を別の名前で保存して、元のレポート定義が上書きされないようにしてください。


セクション、計算、ディメンジョン、またはメジャーの名前を変更するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします。

    -または-

    Report Writer を既に開いている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. 名前を変更する要素 (セクション、計算、ディメンジョン、またはメジャー) をクリックし、新しい名前を入力します。
  4. Enter キーを押します。

注

同じレベルの 2 つの要素 (同じ計算の中の 2 つのメジャーなど) に同じ名前は付けられません。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには
  • レポート定義の要素の名前の変更、要素の削除、または要素の移動


セクション、計算、ディメンジョン、またはメジャーを削除するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします。

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. 削除する要素 (セクション、計算、ディメンジョン、またはメジャー) をクリックします。
  4. [編集] メニューの [削除] をクリックします。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには
  • レポート定義の要素の名前の変更、要素の削除、または要素の移動


セクション、計算、ディメンジョン、またはメジャーを移動するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックします。次に、[OK] をクリックします。

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Open Report Writer カタログ] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. 移動する要素 (セクション、計算、ディメンジョン、またはメジャー) をクリックし、要素を適切な場所にドラッグします。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには
  • レポート定義の要素の名前の変更、要素の削除、または要素の移動


レポート定義を選択する

レポート定義からレポートを実行する場合に、レポート定義によってレポートの構造が表示され、収集するデータに関する情報が提供されます。さまざまな情報をすばやく収集したり、必要に応じて標準のレポートを変更するには、Report Writer カタログから標準レポートを実行します。標準レポート定義の変更またはレポート定義の新規作成の前に、レポート定義の要素を理解しておいてください。

レポート定義を表示する と、レポート定義からレポートを実行する場合に、収集するデータを判定するのに便利です。表示したレポート定義が要求に合うと判断した場合、そのレポートを実行できます。

関連項目

  • 標準レポート リファレンス ガイド
  • レポート定義の要素について


レポート定義を表示するには

レポート定義にはレポートの構造が表示されます。フィルタをルート レベルに追加したり、その他のレポート定義の要素 (セクション、計算、ディメンジョン、およびプレゼンテーション) を追加、削除、または変更できます。

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします。

    -または-

    既に Report Writer を起動している場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーからレポート定義を選択します。[編集] をクリックします。

    選択したレポート定義のセクション、計算、ディメンジョン、およびメジャーがレポート定義ウィンドウに表示されます。ツリーを展開および縮小してレポート定義のすべての要素を表示できます。

関連項目

  • Report Writer を起動するには


レポートを実行するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックし、[OK] をクリックします。

    -または-

    Report Writer をすでに起動している場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. [ファイル] メニューの [レポートの実行] をクリックします。
  4. [ファイル名] ボックスに、レポート ファイル名を入力します。
  5. [形式] ボックスの一覧でファイル形式をクリックします。デフォルトは HTML です。Microsoft® Word 97 または Microsoft® Excel 97 の形式を選択するには、これらがコンピュータにインストールされている必要があります。
  6. [OK] をクリックします。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには


Report Writer カタログからレポートを実行する

Report Writer カタログには標準レポート定義があり、[Custom]、[Detail]、[Intranet]、および [Summary] の 4 つのフォルダに分類されています。簡単な手順に従って、Report Writer カタログからレポートを実行できます。レポートを生成するときに、以下の変更を行うこともできます。

  • 分析するサイトを指定する (Usage Import で複数のサイトを設定している場合にだけ利用可能)。
  • 分析する情報の日付の範囲を指定する。
  • 特定の情報をフィルタ処理する。
  • レポート定義の要素を削除または変更するか、ルート レベルでフィルタを追加する。

関連項目

  • 標準レポート リファレンス ガイド


Report Writer カタログからレポートを実行するには

この手順は、標準レポート定義など、Report Writer カタログに表示されるすべてのレポート定義に対して実行できます。

  1. Report Writer を起動し、[Report Writer カタログ] をクリックし、[OK] をクリックします。

    既に Report Writer を起動している場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. 実行するレポート定義をクリックします。レポート定義を変更する場合は、[次へ] をクリックします。レポートを変更しない場合は、[実行] をクリックし、手順 9. に進みます。
  3. 複数のサイトを設定している場合は、次に表示されるウィンドウで分析するサイトを選択できます。必要に応じて、分析するサイトを指定し、[次へ] をクリックします。
  4. 分析する日付の範囲を指定し、[次へ] をクリックします。
  5. 必要に応じて、レポートにフィルタを適用します。フィルタはレポート定義のすべての計算に適用されます。 [現在のフィルタの新しい式を作成します] の下の [ディメンジョン] ボックスに、フィルタ名として追加するディメンジョンを入力します。
  6. [条件] ボックスに、演算子を入力します。
  7. [値] ボックスに値を入力し、[追加] をクリックします。

    すべてのフィルタが [フィルタに一致するレコードのみを分析します] ボックスに表示されます。さらにフィルタを追加するには、手順 5. ～ 7. を繰り返します。複数のフィルタは "and" または "or" で区切ります。

  8. レポート定義の要素 (セクションや計算など) を削除または変更する場合は、[編集] をクリックします。

    レポート定義の構造を変更しない場合は、[実行] をクリックします。

  9. [実行] をクリックした場合は、[レポート ドキュメント] ダイアログ ボックスの [ファイル名] ボックスに、レポート ファイル名を入力します。

    [編集] をクリックした場合は、表示されたレポート定義を編集できます。レポート定義の編集が終わったら、レポートを実行できます。[編集] をクリックした場合は、以降の手順を実行する必要はありません。

  10. [形式] ボックスの一覧でファイル形式をクリックします。デフォルトは [HTML] です。
  11. レポートにテンプレートを使用するには、[テンプレート] をクリックし、[ファイル名] ボックスにテンプレートのファイル名を入力します。

注

Microsoft Site Server Express ではテンプレートを作成できません。ただし、Microsoft Site Server で作成したテンプレートを利用することはできます。

  12. [OK] をクリックします。

注

レポートを実行すると、そのレポートに関する統計情報が表示されます。この統計情報から、個々の計算にかかる時間、エラー条件、およびレポートの合計実行時間がわかります。

関連項目

  • Report Writer を起動するには
  • フィルタについて


レポート定義を保存するには

レポートを再度実行するときに定義を作成し直さずに済むように、変更したレポート定義を保存できます。

  1. [ファイル] メニューの [レポート定義の保存] または [レポート定義に名前を付けて保存] をクリックします。複数のレポート定義を保存する場合は、[すべて保存] をクリックします。
  2. [レポート定義に名前を付けて保存] を選択する場合は、レポートを保存するファイル フォルダを選択します。Report Writer カタログからレポート定義にアクセス可能にするには、[Custom] フォルダを選択します。
  3. [ファイル名] ボックスでレポートのファイル名を入力します。
  4. [保存] をクリックします。

注

レポート定義の保存とレポートの保存は異なります。レポートを実行するときに、レポートのファイル名を入力するように求められます。ファイル名を入力すると、レポートが保存されます。

関連項目

  • Report Writer を起動するには


レポートの形式を指定する

レポートを実行する前に、レポートの表示方法を選択します。たとえば、レポート、セクション、または計算のヘッダーの表示/非表示を切り替えられます。ヘッダーのフォントや色を指定したり、セクションや計算に説明を追加することもできます。テーブルのスタイル、表示、および設計を編集して、プレゼンテーションの形式を指定できます。レポートの表示を制御する方法の詳細については、以下の項目を参照してください。

  • レポート ヘッダーを編集する
  • セクションまたは計算のヘッダーを編集する
  • テーブルを編集する


レポート ヘッダーを編集する

レポート名、レポートの説明、または分析情報を表示するかどうかを選択できます。これらの情報を表示する場合は、テキストのプロパティ (フォントのサイズ、種類、色など) および背景色を指定できます。レポート名を変更したり、選択した説明を使用することもできます。

注

レポート ヘッダーの分析情報を編集するときにレポートの最後に表示されるレポート定義の一覧は、表示/非表示の切り替えが可能です。


レポート名を編集するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックします。次に、[OK] をクリックします。

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. レポート名を表示するにはルート セクションをクリックし、[編集] メニューの [プロパティ] をクリックします。
  4. [ヘッダーの表示設定] タブをクリックし、タブの上部にある [セクション名] をクリックします。
  5. 必要に応じて [テキストのプロパティ] の [フォント] ボックスの一覧で、フォントを選択します。[サイズ] ボックスの一覧では、フォントのサイズを選択します。また、[太字] や [斜体] チェック ボックスを設定することもできます。[色] の横にあるボタンをクリックして色を選択し、[OK] をクリックすると、特定の要素のフォントの色を設定できます。
  6. 要素の背景色を設定するには、[テーブルのセルのプロパティ] で [可視] チェック ボックスをオンにし、[色] の横にあるボタンをクリックします。次に、色を選択し、[OK] をクリックします。

    行った変更は、手順 4. で選択した要素だけに適用されます。テーブルのほかの要素を変更するには、手順 4. から 6. を繰り返します。

  7. テーブルのグリッドラインを表示または非表示にするには、[テーブルのグリッドライン] の [可視] チェック ボックスをオンまたはオフにし、[OK] をクリックします。
  8. レポートの名前を変更するには、ルート セクションをクリックし、新しい名前を入力します。入力が完了したら、Enter キーを押します。
  9. 必要に応じて、レポートを実行します。

    変更内容がレポートに反映されます。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには


レポートの説明を編集するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. レポートの説明を表示する場合は、ルート セクションをクリックし、[編集] メニューの [プロパティ] をクリックします。
  4. [ヘッダーの表示設定] タブをクリックし、タブの上部の [セクションの説明] をクリックします。
  5. 必要に応じて、[テキストのプロパティ] の [フォント] ボックスの一覧でフォントを選択します。[サイズ] ボックスの一覧では、フォントのサイズを選択します。また、[太字] や [斜体] チェック ボックスを設定することもできます。[色] の横にあるボタンをクリックして色を選択し、[OK] をクリックすると、特定の要素のフォントの色を設定できます。
  6. 要素の背景色を設定するには、[テーブルのセルのプロパティ] で [可視] チェック ボックスをオンにし、[色] の横にあるボタンをクリックします。次に、色を選択し、[OK] をクリックします。

    行った変更は、手順 4. で選択した要素だけに適用されます。テーブルのほかの要素を変更するには、手順 4. から 6. を繰り返します。

  7. テーブルのグリッドラインを表示または非表示にするには、[テーブルのグリッドライン] の [可視] チェック ボックスをオンまたはオフにし、[OK] をクリックします。
  8. レポートの説明を編集するには、[説明] タブをクリックし、デフォルトのテキストを必要な説明に書き換えて、[OK] をクリックします。
  9. 必要に応じて、レポートを実行します。

    変更内容がレポートに反映されます。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには


レポート ヘッダーの分析情報セクションを編集するには

次の手順を実行すると、変更内容は実行するすべてのレポートに反映されます。

  1. Report Writer を起動し、[ツール] メニューの [オプション] をクリックします。
  2. [レポート プレゼンテーション] タブをクリックします。
  3. レポートに分析情報を表示するには、[レポート ヘッダー テキスト] 領域の [可視] チェック ボックスをオンにします。
  4. 必要に応じて、[フォント] ボックスの一覧でフォントを選択します。[サイズ] ボックスでは、フォントのサイズを選択します。[太字] と [斜体] チェック ボックスの設定をすることもできます。フォントの色を設定するには、[色] の横にあるボタンをクリックして色を選択し、[OK] をクリックします。
  5. レポート ヘッダー テキストの背景色を設定するには、[レポートの本文] の [背景色] の下にあるボタンをクリックし、色を選択して [OK] をクリックします。

  6. 変更内容をデフォルト設定にするには、[この設定を保存] をクリックします。
  7. レポートの最後に表示される定義の一覧を非表示にするには、[レポート コンテンツ] タブをクリックし、[定義] の下の [レポート内に含める] チェック ボックスをオフにします。定義を常に非表示にするには、[この設定を保存] をクリックします。この操作をしないと、Report Writer を終了したときに変更内容が保存されません。
  8. [OK] をクリックします。

関連項目

  • Report Writer を起動するには
  • レポートを実行するには


セクションまたは計算のヘッダーを編集する

セクションまたは計算のヘッダーを編集すると、セクションまたは計算のヘッダーと説明の表示/非表示を切り替えられます。ヘッダーと説明を表示する場合は、テキストのプロパティ (フォントのサイズ、種類、色、および太字または斜体であるかどうか) および背景色を指定できます。さらに、独自の説明を入力でき、セクションや計算に説明を付け加える場合に便利です。


セクションまたは計算のヘッダーを編集するには

注

次の手順はセクションの場合について説明しています。計算の場合も操作手順は同じです。

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします。

    -または-

    Report Writer を既に起動している場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. セクションのアイコンをクリックし、[編集] メニューの [プロパティ] をクリックして、[ヘッダーの表示設定] タブをクリックします。
  4. セクション名を表示するには、タブ上部の [セクション名] をクリックします。
  5. 必要に応じて、[テキストのプロパティ] の [フォント] ボックスの一覧で、フォントを選択します。[サイズ] ボックスの一覧では、フォントのサイズを選択します。また、[太字] や [斜体] チェック ボックスを設定することもできます。[色] の横にあるボタンをクリックして色を選択し、[OK] をクリックすると、特定の要素のフォントの色を設定できます。
  6. 背景色を設定するには、[テーブルのセルのプロパティ] で [可視] チェック ボックスをオンにし、[色] の横にあるボタンをクリックします。次に、色を選択し、[OK] をクリックします。

    行った変更は、[セクション名] だけに反映されます

  7. テーブルのグリッドラインを表示または非表示にするには、[テーブルのグリッドライン] の [可視] チェック ボックスをオンまたはオフにします。
  8. レポートに説明を表示するには、タブ上部の [セクションの説明] をクリックし、手順 5. から 7. を繰り返します。
  9. 独自の説明を入力するには、[説明] タブをクリックし、デフォルトのテキストを必要な説明に書き換えます。
  10. セクション名を変更する場合は、セクションのアイコンをクリックし、新しい名前を入力します。入力が完了したら、Enter キーを押します。
  11. 必要に応じて、レポートを実行します。

    変更内容がレポートに反映されます。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには


テーブルを編集する

テーブルの要素は、行ディメンジョン タイトル、行ディメンジョン、行番号、列ディメンジョン タイトル、列ディメンジョン、メジャー タイトル、およびメジャーで構成されます。テーブルの要素をカスタマイズするためのオプションがいくつか用意されています。テーブルの各要素についてテキストのプロパティ (フォントのサイズ、種類、色、太字、または斜体) を指定できます。要素の背景色およびテーブルに要素を表示するかどうかを指定することもできます。行や列の間の罫線 (グリッド ライン) の表示/非表示を切り替えられます。

メジャーをテーブルの行と列のどちらで表示するかを選択できます。1 つの計算に複数のメジャーが使用されている場合は、このオプションを使用して表示方法を制御すると便利です。デフォルトでは、メジャーは列で表示されます。次の図は、このオプションを使用した場合の表示例です。例に用いた計算には、行ディメンジョンの "ファイル名" のほかに、"要求数" および "訪問数" の 2 つのメジャーが使用されています。

テーブルの 最大行数および最大列数を制限できます。これは、テーブルが大きくならないように確認する場合に便利です。テーブル内のデフォルトの最大行数は 500 行、最大列数は 50 列です。

レポート定義でディメンジョンとして "タイトル" を指定している場合で、HTML タイトル検索を実行したときには、ドキュメント タイトルを表示するオプションを選択できます。HTML タイトル検索でタイトルが見つからなかった場合は、タイトルを表示するか、ファイル名を表示するかを選択できます。タイトルとファイル名の両方を表示することもできます。

関連項目

  • データベース中のデータの品質を高める


テーブルの要素をカスタマイズするには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします。

    -または-

    既に Report Writer を起動している場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. テーブルのアイコンをクリックし、[編集] メニューの [プロパティ] をクリックします。
  4. [デザイン] タブをクリックします。タブの上部で、変更する要素をクリックします (たとえば、[列のディメンジョンのタイトル])。
  5. 必要に応じて、[テキストのプロパティ] の [フォント] ボックスの一覧でフォントを選択します。[サイズ] ボックスの一覧では、フォントのサイズを選択します。また、[太字] や [斜体] チェック ボックスを設定することもできます。[色] の横にあるボタンをクリックして色を選択し、[OK] をクリックすると、特定の要素のフォントの色を設定できます。
  6. 特定の要素の背景色を設定するには、[テーブルのセルのプロパティ] で [可視] チェック ボックスをオンにし、[色] の横にあるボタンをクリックします。次に、色を選択し、[OK] をクリックします。

    行った変更は、手順 3. で選択した要素だけに適用されます。テーブルのほかの要素を変更するには、手順 3. から 5. を繰り返します。

  7. テーブルのグリッドラインを表示または非表示にするには、[テーブルのグリッドライン] の [可視] チェック ボックスをオンまたはオフにします。
  8. [OK] をクリックします。
  9. レポートの定義の変更が終了したら、レポートを実行します。

    変更内容がレポートに反映されます。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには


ドキュメント タイトルを表示するオプションを選択するには

次の手順は、レポート定義で "タイトル" がディメンジョンとして指定されている場合にだけ実行してください。

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします。

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. 変更するテーブルのアイコンをクリックし、[編集] メニューの [プロパティ] をクリックします。
  4. [詳細] タブをクリックし、[タイトルまたはタイトルが利用不可の場合ファイル名を表示] または [タイトルおよびファイル名の両方を表示] をクリックします。
  5. [OK] をクリックします。
  6. レポート定義の変更が終了したら、レポートを実行できます。

    変更がレポートに反映されます。

注

ディメンジョン "タイトル" を含むレポートを実行する前に、タイトル検索を実行しておく必要があります。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには
  • データベース中のデータの品質を高める


メジャーをテーブルの行と列のどちらで表示するかを選択するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして [OK] をクリックします。

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. 変更するテーブルのアイコンをクリックし、[編集] メニューの [プロパティ] をクリックします。
  4. [詳細] タブをクリックし、[メジャー] の [メジャーを次の項目として表示] ボックスの一覧で、[カラム] または [行] をクリックします。
  5. [OK] をクリックします。
  6. レポートの定義の変更が完了したら、レポートを実行します。

    変更がレポートに反映されます。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには


テーブルの行や列の数を制限するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックし、[OK] をクリックします。

    -または-

    Report Writer をすでに起動している場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. テーブルのアイコンをクリックし、[編集] メニューの [プロパティ] をクリックします。
  4. [詳細] タブをクリックし、[テーブルの行の最大数] ボックスに行数を入力します。
  5. [テーブルの列の最大数] ボックスに、列数を入力します。
  6. [OK] をクリックします。
  7. レポート定義の変更が終了したら、レポートを実行できます。

    変更内容がレポートに反映されます。

注

テーブルのサイズを制限し、テーブル内のデータの種類も制限するには、行数や列数を制限する代わりに、ディメンジョンの結果を制限します。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには


フィルタについて

フィルタを使用すると、データベース内のデータのある部分を分析できます。たとえば、レポートに 1 か月間のデータだけを含めたり、米国のユーザーに関するレポートの一覧だけを含められます。

ルート セクションに、フィルタを追加できます。

一般的には、ディメンジョンをフィルタ名として使用します。たとえば、フィルタ名が (年 = 1997) であれば、そのディメンジョンは "年" です。フィルタ処理は、任意のディメンジョンについて可能です。メジャーをフィルタ名として使用することもできます。メジャーをフィルタ名として使用することもできます。しきい値を確立する場合は、フィルタ名にメジャーを使用すると便利です。たとえば、過去 7 日間に 3 回以上サイトにアクセスしたすべての訪問者を提示するレポートが作成できます。

注

時間でフィルタ処理を行う場合 ((月 = 1) など) は、相対日付フィルタを使用して再利用可能なレポートを設定できます。たとえば、毎週、その週のトラフィックのデータを分析するレポートを実行するには、相対フィルタ (週 = "今週") を使用します。これによって、毎週フィルタを編集して、7 日前から当日の日付までのトラフィックを含むようにする必要がなくなります。

場合によっては、フィルタのパスを指定しなければならないことがあります。

関連項目

  • フィルタ構造について
  • レポート定義の要素について
  • ディメンジョン リファレンス ガイド


フィルタ構造について

フィルタは、名前と値の対から成るブール式です。基本的なフィルタは、名前、演算子、値で構成され、構文は <フィルタ名><演算子><値> となります。たとえば、フィルタ (年 = 1997) の場合は、"年" がフィルタ名、= が演算子、1997 が値です。ブール式 (AND または OR) を使用して、より複雑なフィルタを作成できます。両方の式が真である場合にフィルタを真にするには、AND を使用します。いずれかの式が真である場合にフィルタを真にするには、OR を使用します。たとえば、(ファイル名 = "/index.html") AND (日付 = "火曜日") というフィルタを追加すると、このファイルを火曜日に要求したユーザーだけに関するデータを収集できます。また、フィルタ (月 = 1) OR (月 = 2) を追加すると、1 月 と 2 月の両方のデータを収集できます。

フィルタ名には任意のディメンジョン ("年"、"Referring Organization"、"ホスト名" など) を使用できます。メジャーをフィルタ名として使用する場合は、そのメジャーを表す適切な名前をフィルタ名に使用します。

名前によって使用できる値は異なります。一般的に値は、日付、整数、文字列、相対日付フィルタの値のいずれかです。値には以下のガイドラインが適用されます。

  • 整数にカンマは使用できません (たとえば、1000)
  • 文字列では大文字小文字は区別されません。たとえば、France と france は同様に処理されます。
  • スペースを含む文字列は二重引用符で囲む必要があります。スペースを含まない文字列の場合は、二重引用符を省略できます (たとえば、"John Doe")。
  • フィルタの式では改行は無視されます。

次の表は、相対日付フィルタ値の一覧です。

ディメンジョン名 | 値
年 | 今年、昨年
四半期 | 今四半期、昨四半期
月 | 今月、先月
週 | 今週、先週
日付 | 今日、昨日

注

相対値に "[-+]#" を追加すると、その時間が元の相対時間の前後に追加されます。たとえば、値が Today-2 である場合は、2 日前のデータが分析されます。

フィルタに以下のワイルドカードの値を追加できます。

文字 | 説明 | 例
* | 任意の数の文字に一致します。文字列の最初または最後の文字として使用できます。 | d* は Debra および David に一致します。
? | 任意のアルファベット 1 文字に一致します。 | jo?n は John および Joan に一致します。
[ ] | 角かっこ内の任意の 1 文字に一致します。 | [jt]erry は Jerry および Terry に一致しますが、Kerry には一致しません。
! | 角かっこ内にない任意の 1 文字に一致します。 | [!jt]erry は Kerry に一致しますが、Jerry や Terry には一致しません。
- | ある範囲の任意の 1 文字に一致します。範囲は昇順に指定する必要があります (Z から A ではなく、A から Z) | [c-e]d は cd、dd、および Ed に一致します。

注

*、?、[、!、または - を検索する場合は、検索する文字を角かっこで囲む必要があります。たとえば、cgi[-]bin は cgi-bin に一致します。

演算子は名前と値の関係を定義します。次の表は、演算子の一覧です。

演算子 | 説明 | 例
= | 名前と値が等しい。 | 国 = "France"
<> | 名前と値が等しくない | 国 <> "France"
< | 名前が値未満である。 | 時間 < 12
> | 名前が値よりも大きい。 | 時間 > 12
>= | 名前が値以上である。 | 時間 >= 12
<= | 名前が値以下である。 | 時間 <= 12

フィルタに NOT を追加することもできます。これは、複数の値を持つディメンジョンを使用し、フィルタで指定した値に適合するすべてのユーザーを除外する場合に便利です。たとえば、User ディメンジョン カテゴリに、"Activities" などの複数の値を持つディメンジョンがあるとします。ユーザーにはそれぞれ Activities のセットがあり、Activities に Knitting を含むすべてのユーザーを除外するレポートを実行するとします。NOT を使用すると、Activities に Knitting を含むユーザーを効率的に除外できます。NOT を使用する場合は、ディメンジョンへのパスを指定し、パスとディメンジョンの間に NOT を挿入する必要があります。たとえば、フィルタ (User.Not.Activities = "Knitting") を使用すると、Activities に Knitting が含まれるユーザーが除外されます。

注

複合パスと NOT を組み合わせると、レポートの実行に必要な時間が大幅に増加する場合があるのでお勧めしません。

演算子 <> と NOT の違いは、NOT の方が包括的である点です。たとえば、User ディメンジョン カテゴリに、複数の値を持つディメンジョン "Interest" があるとします。ユーザーにはそれぞれ Interest のセットがあり、その 1 つに Sports が含まれる場合があるとします。フィルタ (User.Interest <> "Sports") を使用すると、唯一の Interest が Sports であるユーザーだけがレポートから除外されます。複数の Interest を持ち、その 1 つが Sports であるユーザーは除外されません。ただし、フィルタ (User.Not.Interest = "Sports")を使用すると、Interest に Sports を含むすべてのユーザーを除外できます。

関連項目

  • メジャーをフィルタ名として使用する
  • レポート定義の要素について
  • ディメンジョン リファレンス ガイド
  • フィルタについて
  • フィルタのサンプル


メジャーをフィルタ名として使用する

フィルタ名にはディメンジョンを使用するのが一般的です。ただし、メジャーをフィルタ名として使用することもできます。しきい値を確立する場合は、フィルタ名にメジャーを使用すると便利です。たとえば、過去 7 日間にサイトにアクセスしたすべての訪問者を提示するレポートを作成できます。この場合は、(週 = "先週") AND (Visit.Count >= 3) というフィルタを使用します。メジャーをフィルタ名として使用する場合、通常、フィルタの値には整数を用います。

計算の中でメジャーをフィルタ名として使用すると、レポートでは、その計算のディメンジョンに対応したデータが返されます。たとえば、フィルタ (Visit.Count > 300) をディメンジョン "日付" と共に使用すると、レポートでは、300 以上の訪問があったすべての日に関するデータが返されます。サイトのサイズによっては、このフィルタを使用すると、データの大部分が除外されます。"年" ディメンジョンを使用した場合、レポートでは、300 以上の訪問があったすべての年に関するデータが返されます。

次は、メジャーをフィルタ名として使用したフィルタの一覧です。

名前 | 説明
Request.count | 要求数をカウント
Request.duration | 要求の時間を測定
Visit.count | 訪問数をカウント
Visit.duration | 訪問の時間を測定
User.count | ユーザー数をカウント
Organization.count | 組織数をカウント
Hits.count | ヒット数をカウント
Bytes.count | バイト数をカウント

関連項目

  • フィルタについて
  • フィルタ構造について
  • フィルタを追加する


フィルタのパスを指定する

フィルタは通常メジャーと同じパスにあるので、一般的にはフィルタのパスを指定する必要はありません。フィルタのパスを指定しない場合は、計算のメジャーが割り当てられているのと同じパスにフィルタが割り当てられます。たとえば、すべての組織の全ユーザーについて、"最初の要求" が行われた sports ディレクトリ内のファイルを調べるとします。この計算を設定するには、[メジャーのプロパティ] ダイアログ ボックスのツリーで、[訪問]、[訪問中の最初の訪問] とたどった先の [要求数] をメジャーに指定します。これにより、"Visit.FirstRequest.Number of Requests" というパスが定義されます。次に、[ディメンジョン プロパティ] ダイアログ ボックスのツリーで、[訪問]、[訪問中の最初の要求]、[コンテンツ] とたどった先の [ファイル名] をディメンジョンに指定します。これにより、"Visit.FirstRequest.Content.ファイル名" というパスが定義されます。また、フィルタは、(ファイル名 = "/sports*") と定義します。この場合は、ディメンジョン、メジャー、およびフィルタはすべての訪問の最初の要求に関係するので、フィルタのパスを指定する必要はありません。

パス 1 の例

sports ディレクトリのどのファイルが、任意の組織のすべてのユーザーのすべての訪問における "2 番目の要求" であるかを調べる場合は、[メジャーのプロパティ] ダイアログ ボックスのツリーで、[訪問]、[訪問中の最初の訪問]、[訪問中の 2 番目の要求] とたどった先の [要求数] をメジャーに指定します。これにより、"Visit.FirstRequestNextRequest.Number of Requests" というパスが定義されます。次に、[ディメンジョン プロパティ] ダイアログ ボックスのツリーで、[訪問]、[訪問中の最初の要求]、[訪問中の 2 番目の要求]、[コンテンツ] とたどった先の [ファイル名] をディメンジョンに指定します。これにより、"Visit.FirstRequestNextRequest.Content.ファイル名" というパスが定義されます。また、フィルタは (ファイル名 = /sports*) と定義します。この場合も、ディメンジョン、メジャー、およびフィルタはすべて、任意の訪問の 2 番目の要求に関係するので、フィルタのパスを指定する必要はありません。

パス 2 の例

メジャーとは異なるパスにフィルタを設定する場合は、フィルタのパスを指定する必要があります。たとえば、sports ディレクトリから始まる訪問で発生する各ファイルの 2 番目の要求数を調べるとします。[メジャーのプロパティ] ダイアログ ボックスのツリーで、[訪問]、[訪問中の最初の訪問]、[訪問中の 2 番目の要求] とたどった先の [要求数] をメジャーに指定します。これにより、"Visit.FirstRequestNextRequest.Number of Requests" というパスが定義されます。次に、[ディメンジョン プロパティ] ダイアログ ボックスのツリーで、[訪問]、[訪問中の最初の要求]、[訪問中の 2 番目の要求]、[コンテンツ] とたどった先の [ファイル名] をディメンジョンに指定します。これにより、"Visit.FirstRequestNextRequest.Content.ファイル名" というパスが定義されます。また、フィルタを (VisitFirstRequest.ファイル名 = /sports*) と定義します。この場合は、フィルタは訪問の最初の要求に関連し、メジャーとディメンジョンは訪問の 2 番目の要求に関連するので、フィルタのパスを指定する必要があります。

パス 3 の例

フィルタでパスを指定する場合の構文

パスは、ディメンジョンの階層順、つまり Organization (組織)、User (ユーザー)、Visit (訪問)、Request (要求) の順に指定する必要があります。パスの最後は、フィルタ名が存在するディメンジョン カテゴリに対応します。たとえば、(ブラウザ製品 = "Netscape") についてフィルタ処理する場合、"ブラウザ製品" は Visit ディメンジョンです。したがって、このフィルタのパスは "Organization.FirstUser.LastVisit" となり、Visit ディメンジョン カテゴリで終わっています。フィルタのパスを指定する場合は、<パス.ディメンジョン><演算子><値> (たとえば、(User.FirstVisit.FirstRequest.NextRequest.file <> Index.htm) または (UFVFRNR.file <> index.htm)) という構文を使用します。

パス全体 ("Organization.FirstUser.FirstVisit.Request" など) を入力することも、ショートカットを使用することもできます。

次の表は、基本的なショートカットの省略形の一覧です。

パス要素 | 省略形 | パス要素 | 省略形
Visit | V | Every request | ER
Every visit | EV | Previous request | PR
Last visit | LV | User | U
First visit | FV | Every user | EU
First request | FR | Last user | LU
Last request | LR | First user | FU
Next request | NR | Organization | O

次の表は、ショートカットの例です。

フル パス | 説明 | ショートカット
Visit.firstrequest | 訪問の最初の要求 | VFR
Visit.firstrequest.nextrequest | 訪問の 2 番目の要求 | VFRNR
Visit.everyrequest | 訪問のすべての要求 | VER
Visit.everyrequest.previousrequest | 分析中の要求の前の要求 | VERPR
Visit.everyrequest.nextrequest | 分析中の要求の次の要求 | VERNR
Visit.lastrequest | 訪問の最後の要求 | VLR
Visit.lastrequest.previousrequest | 訪問の最後から 2 番目の要求 | VLRPR
User.firstvisit.firstrequest | ユーザーの最初の要求 | UFVFR
User.firstvisit.everyrequest | ユーザーの最初の訪問のすべての要求 | UFVER
User.firstvisit.lastrequest | ユーザーの最初の訪問の最後の要求 | UFVLR
User.everyvisit.firstrequest | Visit.firstrequest と同じ | UEVFR
User.everyvisit.everyrequest | Visit.everyrequest と同じ | UEVER
User.everyvisit.lastrequest | Visit.lastrequest と同じ | UEVLR
User.lastvisit.firstrequest | ユーザーの最後の訪問の最初の要求 | ULVFR
User.lastvisit.everyrequest | ユーザーの最後の訪問のすべての要求 | ULVER
Organization.firstuser | 組織の最初のユーザー | OFU
Organization.firstuser.firstvisit | 組織の最初のユーザーの最初の訪問 | OFUFV
Organization.firstuser.everyvisit | 組織の最初のユーザーのすべての訪問 | OFUEV
Organization.everyuser.lastvisit | 組織のすべてのユーザーの最後の訪問 | OEULV


フィルタのサンプル

次の表はフィルタのサンプルです。

目的 | フィルタ
product ディレクトリのファイルだけを含める。 | file = /product/*
product ディレクトリのファイルを除外する。 | file <> /product/*
最初の要求が product ディレクトリ内のファイルであった訪問だけを含める。 | VFR.file = /product/*
product ディレクトリのファイルだけを含めるが、widget A は除外する。 | (file = /product/*) and (file <> product/widgetA*)
HTML ファイルの要求だけを分析する。 | media = HTML
Microsoft Internet Explorer ブラウザを使用した訪問だけを分析する。 | ブラウザ製品 = Internet Explorer*
1997 年 12 月 25 日のすべてのトラフィックを分析する。 | Date = 12/25/98
前の月のトラフィックを分析する。 | 月 = 先月
去年初めてサイト訪問したユーザーで、今月も訪問したユーザーのトラフィックを分析する。 | (ULV.月 = 今月) AND (UFV.年 = 昨年) または (UEV.月 = 今月) AND (UFV.年 = 昨年)
product ディレクトリのどのファイルも見なかったすべてのユーザーを分析する。 | User.Not.File = /product/*
product 以外のディレクトリで時間を過ごしたすべてのユーザーを分析する。 | User.File <> /product/*


フィルタを追加する

フィルタの追加は、ルート セクションに対して行うことができます。フィルタの詳細については、次の関連項目を参照してください。

  • フィルタについて
  • フィルタ構造について
  • メジャーをフィルタ名として使用する
  • フィルタのパスを指定する
  • フィルタのサンプル


フィルタを追加するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします。

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. ルート セクションをクリックします。
  4. [編集] メニューの [プロパティ] をクリックし、[フィルタ] タブをクリックします。
  5. [現在のフィルタの新しい式を作成します] の [ディメンジョン] ボックスでフィルタとして追加するディメンジョンを入力します。
  6. [条件] ボックスで、適切な演算子を入力します。
  7. [値] ボックスで、適切な値を入力し、[追加] をクリックします。
  8. [フィルタに一致するレコードのみを分析します] ボックスに完全なフィルタが表示されます。
  9. 手順 4. から 7. を繰り返して、ほかのフィルタを追加します。複数のフィルタは、 AND または OR で区切ります。

注

フィルタのバスを指定する場合は、[フィルタに一致するレコードのみを分析します] ボックスにパスを入力する必要があります。

  10. 操作が終了したら、[OK] をクリックします。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには
  • フィルタについて
  • フィルタのパスを指定する


ディメンジョンおよびメジャーについて

データベース内のデータは、4 つのディメンジョン カテゴリ "要求"、"訪問"、"ユーザー"、および "組織" に編成されます。これらの各ディメンジョン カテゴリには多くのディメンジョンが存在します。"日付"、"参照 URL"、"ホスト名"、および "組織の種類" は、すべてディメンジョン カテゴリ内のディメンジョンの例です。ディメンジョンは、通常レポート内のプレゼンテーションを設定するために使用するデータとして機能します。たとえば、ディメンジョン "日付" を使用してレポートを実行し、ある期間の訪問数を測定できます。ディメンジョンには、任意の数のメジャーを関連付けできます。たとえば、メジャー "ヒット数" および "ユーザー数" をディメンジョン "日付" に関連付けると、特定の日のヒット数およびユーザー数を調べられます。

計算では、行ディメンジョンまたは列ディメンジョンを指定できます。行ディメンジョンは、テーブルの行またはグラフの X 軸として表示されます。列ディメンジョンは、テーブルの行またはグラフの X 軸上の小目盛りとして表示されます。これ以外に、行ディメンジョンと列ディメンジョンに違いはありません。

メジャーは、計算においてカウントまたは合計される単一の値です。メジャーは、テーブルの各セルまたはグラフのデータ ポイントとして表示されます。メジャーは、"要求"、"訪問"、"ユーザー"、および "組織" に分類されます。"訪問数" および "要求時間" はメジャーの例です。

計算では、ディメンジョンをメジャーとして使用したり、メジャーをディメンジョンとして使用することができます。

注

場合によっては、ディメンジョンとメジャーのパスを指定する必要があります。

関連項目

  • ディメンジョン リファレンス ガイド


ディメンジョンの出力を制御する

ディメンジョンの結果を制限し、項目を特定の数にしたり、項目の総数を特定のパーセンテージにすることができます。ディメンジョンの結果を制限する場合は、結果を上位または下位の項目数に制限するのか、総数に対するパーセンテージに制限するのかを指定する必要があります。ディメンジョンの結果を制限すると、冗長なレポートを管理する場合に便利です。たとえば、レポートの行数が 500 行を超えることがわかっている場合は、結果を制限し、項目の上位 10% だけをレポートのテーブルに表示できます。

最初のメジャーまたはディメンジョンによって結果を制限することもできます。これによって、プレゼンテーションをプレゼンテーションの値で並べ替えたり、プレゼンテーションのディメンジョンの項目でアルファベット順に並べ替えられます。結果は降順 (下位の項目数または % を選択した場合) または昇順 (上位の項目数または % を選択した場合) に並べ替えられます。

計算のプレゼンテーションがテーブルである場合はディメンジョンを要約し、詳細な値のほかに、計算のメジャーに要約レベルの情報を追加するかどうかを定義できます。選択した要約 (合計、最小、最大、平均、またはメジアン) は、テーブルの要素として表示されます。次の例は、最も一般的なオペレーティング システムを (訪問の % 単位で) 測定する計算において、ディメンジョン "オペレーティング システム" の合計の要約を選択した場合の結果を示しています。

ディメンジョンを要約できるのは、ディメンジョンの階層でディメンジョンがメジャーよりも上の階層である場合だけです。たとえば、"訪問" ディメンジョンの "サイト" および "要求" メジャーの "要求数" を使用する計算がある場合は、"訪問" ディメンジョンはディメンジョンの階層において "要求" ディメンジョンよりも上位であるため要約できます。このプレゼンテーションには、各サイトの要求数の要約が含まれます。


ディメンジョンの結果を制限するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックして、[OK] をクリックします。

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. 変更するディメンションをクリックし、[編集] メニューの [プロパティ] をクリックします。
  4. [結果の最大数] ボックスの一覧で、[上位] または [下位] をクリックします。
  5. 次のボックスに、適切な整数 (たとえば、10) を入力し、次のボックスで [アイテム] または [パーセント] を選択します。

    たとえば、ディメンジョンの結果を上位 10 項目または上位 10% に制限できます。

  6. [並べ替え] ボックスの [最初のメジャー] または [ディメンジョン] をクリックし、[OK] をクリックします。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには
  • ディメンジョンの出力を制御する


ディメンジョンを要約するには

  1. Report Writer を起動し、[Report Writer カタログ] をクリックします。次に、[OK] をクリックします。

    -または-

    Report Writer が既に開かれている場合は、[ファイル] メニューの [Report Writer カタログを開く] をクリックします。

  2. ツリーでレポート定義を選択し、[編集] をクリックします。
  3. 変更するディメンジョンをクリックし、[編集] メニューの [プロパティ] をクリックします。
  4. [オプション] の [要約] ボックスの一覧で、いずれかの集計オプション ([なし]、[合計]、[最小値]、[最大値]、[平均値]、および [メジアン]) を選択し、[OK] をクリックします。

関連項目

  • Report Writer を起動するには
  • レポート定義を表示するには
  • ディメンジョンの出力を制御する


レポートの実行時間を短縮する

レポートの実行にかかる時間を短縮するには、計算のキャッシングを有効にします。計算のキャッシングを使用すると、よく使用する計算を保存して再利用できます。

注

初めてのレポートを実行すると、データベース インデックスが作成されるので、2 回目の実行時間が短縮されます。

実行した計算をキャッシングできます。計算をキャッシングすると、その計算結果はキャッシュ サブディレクトリのファイルに格納されます。このファイルは、同じ計算が含まれているすべてのレポートで利用できます。ファイルのデータと競合するデータを含むログ ファイルをインポートすると、このファイルは削除されます。

注

デフォルトでは、計算はキャッシングされます。


計算をキャッシングするには

  1. Report Writer を起動し、[ツール] メニューの [オプション] をクリックします。
  2. [計算キャッシュ] タブをクリックし、[すべての計算をキャッシュ] チェック ボックスをオンにします。
  3. キャッシュ フォルダを指定する場合は、[キャッシュ フォルダ] ボックスにフォルダ名を入力します。デフォルトは Cache フォルダです。
  4. 最大キャッシュ サイズを変更する場合は、[最大キャッシュ サイズ] に値を入力します。デフォルトでは 5,120KB です。
  5. [OK] をクリックします。

関連項目

  • Report Writer を起動するには
  • レポートの実行時間を短縮する


デフォルトの保存先フォルダを選択する

レポートおよびレポート定義ファイルのデフォルトの保存先フォルダを指定できます。レポートを実行したとき、またはレポート定義を変更したときには、 あらかじめ指定してあった保存先フォルダが使用されます。

注

保存先フォルダのローカル パスを指定する必要があります。


デフォルトの保存先フォルダを指定するには

  1. Report Writer を起動し、[ツール] メニューの [オプション] をクリックします。
  2. [出力先フォルダ] タブをクリックします。
  3. レポートの保存先フォルダを変更する必要がある場合は、[レポート ファイル] ボックスに新しいフォルダ名を入力するか、[参照] をクリックしてフォルダを選択します。
  4. レポート定義の保存先フォルダを変更する必要がある場合は、[レポート定義ファイル] ボックスに新しいフォルダ名を入力するか、[参照] をクリックしてフォルダを選択します。
  5. [この設定を保存] をクリックし、[OK] をクリックします。

関連項目

  • Report Writer を起動するには


ディメンジョン リファレンス ガイド

ディメンジョンについては、以下の一覧を参照してください。

  • "要求" ディメンジョンの一覧
  • "訪問" ディメンジョンの一覧
  • "ユーザー" ディメンジョンの一覧
  • "組織" ディメンジョンの一覧


"要求" ディメンジョンの一覧

次の表に示すディメンジョンは、インポート中に各要求に関連付けられます。

ディメンジョン | 説明 | 値の例
日付 | 要求の日付。 | 97/10/04、97/08/29
タイムスタンプ | 要求の日付と時刻。 | 10/4/97 午後 1:22
時間 | 要求の時刻。 | 0 ～ 23
月 | 1 年の月。 | 97/01/01、97/10/01、1 ～ 12
四半期 | 1 年の四半期。四半期は、1 月、4 月、7 月、および 10 月の 1 日から始まるものとして定義されます。 | 97/01/01、97/04/01、97/07/01、97/10/01
週 | 1 年の週。 | 週の始まりの曜日として指定した日に基づく、週の最初の日付。yy/mm/dd 形式を使用します。
曜日 | 週の曜日。 | 1 ～ 7、日曜日、月曜日
年 | 年。 | 1997
ファイル名 | 要求されたファイル (URL の URI)。 | /index.html, /order*, *.html
レベル 1 ディレクトリ | 要求ファイルが存在するルート ("/") から 1 番目のディレクトリ。ルート ディレクトリはレベル 1 のディレクトリとみなされます。 | /a
レベル 2 ディレクトリ | 要求ファイルが存在するルート ("/") から 2 番目のディレクトリ。 | /a/b/
レベル 3 ディレクトリ | 要求ファイルが存在するルート ("/") から 3 番目のディレクトリ。 | /a/b/c/
レベル 4 ディレクトリ | 要求ファイルが存在するルート ("/") から 4 番目のディレクトリ。 | /a/b/c/d/
レベル 5 ディレクトリ | 要求ファイルが存在するルート ("/") から 5 番目のディレクトリ。 | /a/b/c/d/e/
レベル 6 ディレクトリ | 要求ファイルが存在するルート ("/") から 6 番目のディレクトリ。 | /a/b/c/d/e/f/
メディアの種類 | 要求ファイルのメディアの種類。 | html、gif、jpeg、au、wav
メディアの種類 カテゴリ | メディアの種類のカテゴリ。 | アーカイブ、オーディオ、ドキュメント、イメージ
タイトル | メディアが html の場合は、要求されたファイルの <TITLE>。それ以外の場合は、タイトルはスペースです | "Home page"


"訪問" ディメンジョンの一覧

次の表に示すディメンジョンは、インポート中に各訪問に関連付けられます。

ディメンジョン | 説明 | 値の例
サイト | 発生したアクティビティの対象となったサイト。 | サーバー マネージャに一覧表示されるサイト名。
サーバー | 要求に対してサービスを行ったサーバー。 | サーバー マネージャに一覧表示されるサーバー名。
ログ データ ソース | 要求に対してサービスを行ったログ データ ソース。 | サーバー マネージャに一覧表示されるログ データ ソース名。
参照 URL | 訪問の最初の要求で参照する URL。 | http://www.microsoft.com/awesome_sites.html
国 | ユーザーの接続元の組織がある国。 | Canada
大陸 | ユーザーの接続元の組織がある大陸。 | North America
組織の種類 | ユーザーの接続元の組織の種類。 | 商用、学術、非営利、インターネット サービス プロバイダ、軍事、オンライン サービス
ドメイン | ユーザーの接続元の組織のドメイン。 | Microsoft.com
Zip code | ホスト名のドメインを登録している組織の zip コード (米国のみ) または郵便コード (カナダのみ)。 | 98101
City | ユーザーの接続元の組織がある都市。 | Seattle
State | ユーザーの接続元の組織がある州。 | 完全な州名または郵便で使用される省略形 (California または CA)
Region | ユーザーの接続元の組織がある地域。 | Pacific
ブラウザのバージョン | サイトの表示に使用しているブラウザのバージョン。 | 1.1、 1.1N、 2.0
ブラウザのセキュリティ | ブラウザが対応している暗号化セキュリティのレベル。 | Exportable SSL (40 ビット RC4 暗号)
オペレーティング システム | ユーザーのコンピュータのオペレーティング システム。 | Windows (32 bit)、 UNIX - Sun
ブラウザ製品 | サイトの表示に使用しているブラウザ。 | Microsoft® Internet Explorer, Netscape Navigator.
主なブラウザ | ユーザーが接続に使用している主なブラウザ。 | Internet Explorer、Netscape Navigator、その他のブラウザ製品


"ユーザー" ディメンジョンの一覧

次の表に示すディメンジョンは、インポート中に各ユーザーに関連付けられます。

ディメンジョン | 説明 | 値の例
Cookie | ユーザーを識別するために使用される、クライアントの状態を保存しておく HTTP cookie。 | MICROSOFT_!aQFG@4gd
ホスト名 | このユーザーが使用するホスト名のアドレス。 | example.Microsoft.com
ユーザー名 | サイトに登録されているユーザーのユーザー名。 | Bob


"組織" ディメンジョンの一覧

次の表に示すディメンジョンは、インポート中に各組織に関連付けられます。

注

データベースのディメンジョンを取得するには、まずIP アドレスを解決し、Whois 検索を実行します。

ディメンジョン | 説明 | 値の例
国 | 組織が存在している国。国名はホスト名を解析して判別されます。 | USA、France、Germany、Canada
大陸 | 組織の国が存在している大陸。国名はホスト名を解析して判別されます。 | Asia、Europe、Africa、North America、Central America、South America、Oceania
ユーザー名 | サイトに登録されているユーザーのユーザー名。 | Bob
ドメイン | 組織を一意に識別するホスト名の部分。 | Microsoft.com
組織名 | ホスト名のドメインを登録している組織の名前。 | Any Corporation
組織所在地の郵便番号 | ホスト名のドメインを登録している組織の zip コード (米国のみ) または郵便コード (カナダのみ)。 | 94086、94087
組織所在地の市町村 | ホスト名のドメインを登録している組織がある都市 (米国およびカナダのみ) | Sunnyvale、Palo Alto、New York、Los Angeles など
組織所在地の都道府県 | ホスト名のドメインを登録した組織がある州 (米国およびカナダのみ)。 | 完全な州名、または郵便で使用される略称 (California または CA)
組織の所在地域 | ホスト名のドメインを登録した組織がある地理的な地域 (米国のみ)。 | New England、Mid-Atlantic、East North Central、West North Central
組織の種類 | ホスト名を解析して判別される組織の種類。 | 商用、学術、非営利、インターネット サービス プロバイダ、行政、軍事、オンライン サービス


標準レポート定義リファレンス ガイド

Report Writer カタログの以下のレポートのフォルダに、それぞれ標準レポートが用意されています。

  • イントラネット レポート
  • 詳細レポートおよび要約レポート

注

Report Writer カタログには、Custom という名前のフォルダも用意されています。作成したレポート定義を [Custom] フォルダに保存し、後で Report Writer カタログからそのレポート定義を利用できます。


イントラネット レポート

次の表は、イントラネット レポートについての説明です。

レポート | このレポートの用途 | 要件
イントラネット コンテンツ レポート | イントラネット上のコンテンツがどのように使用されているかを確認する。 | なし

各レポートについては、それぞれの標準レポートのレポート定義を参照してください。

関連項目

  • レポート定義を表示するには


詳細レポートおよび要約レポート

次の表は、Report Writer カタログの [詳細] フォルダおよび [要約] フォルダに用意されている標準レポート定義についての説明です。どちらのフォルダのレポート定義でも同じ種類の情報が得られますが、[詳細] フォルダのレポート定義を使用した方がより詳細な情報が得られます。

レポート | このレポートの用途 | 最適な結果を得る方法 | 要件
帯域幅のレポート | バイト転送における傾向を見極める。 |  |
ブラウザとオペレーティング システムのレポート | ブラウザおよびオペレーティング システムに関する情報を収集する。 |  | ユーザー エージェントのデータを含む拡張ログ ファイル。
サイトの総合分析レポート (詳細レポートのみ) | サイトの利用状況に関する詳細情報を得る。 | IP アドレスを解決し、Whois 検索および HTML タイトル検索を実行します。 |
コンテンツ レポート | サイトのディレクトリ構造全体に、メディアの種類のカテゴリおよびメディアの種類がどのように分布しているかを調べる。 |  |
エグゼクティブの要約レポート(要約レポートのみ) | サイトの利用状況に関する概要を知る。 | IP アドレスを解決し、Whois 検索および HTML タイトル検索を実行します。 |
エグゼクティブの要約レポート (拡張ログ) (要約レポートのみ) | サイトの利用状況に関する概要を知る。 | IP アドレスを解決し、HTML タイトル検索および Whois 検索を実行します。 | 参照元およびユーザー エージェントのデータを含む拡張ログ ファイル。
地域のレポート | サイト訪問者がどこからアクセスしているかを調べる。 | IP アドレスを解決し、Whois 検索を実行します。 |
ヒット数のレポート | サーバーへのヒットについて調べる。 |  |
組織のレポート | サイトを訪問している組織を調べる | IP アドレスを解決し、Whois 検索を実行します。 |
パスのレポート | ユーザーがサイト内で使用する経路を調べる | HTML タイトル検索を実行します。 |
参照元のレポート | サイトを参照している組織を調べます。 | IP アドレスを解決します。 | 参照元のデータを含む拡張ログ ファイル。
要求のレポート | サイトで最も要求が多い文書と最も要求が少ない文書を調べる。 | HTML タイトル検索を実行します。 |
ユーザーのレポート | 訪問の合計数およびユーザーによるサイトの訪問時間を計算する。 |  | cookie のデータを含む拡張ログ ファイル
訪問のレポート | ユーザーによる訪問の傾向を見極め、ユーザーによるサイトの訪問頻度を監視する。 |  |

各レポートについては、それぞれの標準レポートのレポート定義を参照してください。

関連項目

  • データベース中のデータの品質を高める
  • レポート定義を表示するには


Analysis データベースの管理

Usage Import および Report Writer を操作するには、データベースに接続する必要があります。Microsof® Site Server Express Analysis のインストール中に、Analysis データベースは自動的に設定されます。データベースのパフォーマンスの最適化、データベースの新規作成、別のデータベースへの接続、データベースの内容の表示など、設定したデータベースを管理するための操作について説明します。

関連項目

  • データベースを圧縮する
  • 複数のデータベースを作成する
  • 別のデータベースに接続する
  • データベースの内容を表示する


データベースを圧縮する

定期的にそのデータベースを圧縮すると、 データベースのサイズを管理しやすい大きさに保ち、データベースのパフォーマンスを最適な状態に維持できます。


データベースを圧縮するには

  1. Usage Import または Report Writer を起動します。
  2. [ツール] メニューの [データベースの最適化] をクリックします。
  3. ダイアログ ボックスが表示されたら、[はい] をクリックして続行します。

    データベースが圧縮されると、ダイアログ ボックスで圧縮されたデータベースのバイト数が通知されます。

  4. [OK] をクリックします。

関連項目

  • Usage Import を起動するには
  • Report Writer を起動するには


複数のデータベースを作成する

Microsoft® Site Server Express Analysis のインストール中に、Analysis データベースは自動的に設定されます。ほとんどの組織ではデータベースが 1 つあれば十分ですが、組織の必要に応じて 別のデータベースを作成する場合もあります。たとえば、システム パフォーマンスを最適化したり、一部のユーザーがアクセスできるデータを制限したりするために、複数の小規模データベースを作成する場合があります。

注意

複数のデータベースを作成する場合は、それぞれのデータベースにどのログ ファイルをインポートするかを慎重に計画する必要があります。データベースが異なるサイトのデータは、同時に分析できないためです。たとえば、サイトが 2 つあり、それぞれのサイトに関連付けられているデータを別のデータベースにインポートすると、これら 2 つのサイトのデータを組み合わせるレポートを実行できません。


データベースを作成するには

  1. Usage Import を起動します。
  2. [ファイル] メニューの [新規データベース] をクリックします。
  3. [ファイル名] ボックスで必要なデータベース名を入力し、 [保存] をクリックします。
  4. データベースの作成が正常終了したことを表すダイアログ ボックスが表示されたら、[OK] をクリックします。

関連項目

  • Usage Import を起動するには


別のデータベースに接続する

Usage Import、または Report Writer で現在使用中のデータベースは、次の例に示すように、プログラム ウィンドウの下部のステータス バーに表示されます。

複数のデータベースを作成すると、簡単に別のデータベースに接続できます。


別のデータベースに接続するには

  1. Usage Import を起動します。
  2. [ファイル] メニューの [データベースを開く] をクリックします。
  3. 接続するデータベースをクリックし、[開く] をクリックします。

関連項目

  • Usage Import を起動するには


データベースの内容を表示する

Usage Import および Report Writer から現在接続しているデータベースの内容を表示できます。次の表は、データベースの内容を表示するときに利用できる情報です。

列 | 表示内容
[ログ データ ソース] | サーバー マネージャで設定し、データベースにデータをインポートした、すべてのログ データ ソース。
[サーバー] | サーバー マネージャで設定し、データベースにデータをインポートした、すべてのサーバー (Web サーバー、FTP サーバー、およびリアルタイム ストリーム サーバー)。
[サイト] | サーバー マネージャで設定し、データベースにデータをインポートしたすべてのサイト。
[サイト ID] | サーバー マネージャで設定したサイトに自動的に割り当てられた SiteID。
[最初の要求日時] | サイトにインポートされた最初の要求日付。
[最後の要求日時] | サイトにインポートされた最後の要求日付。


データベースの内容を表示するには

  1. Usage Import または Report Writerを起動します。
  2. [ファイル] メニューの [データベース コンテンツ] をクリックします。
  3. データベースの内容表示を終了するには、[データベース コンテンツ] ウィンドウを閉じます。

注

いずれかの要素を基に表を並べ替えるには、列の見出しをダブルクリックします。

関連項目

  • Usage Import を起動するには
  • Report Writer を起動するには


アクティビティのスケジュール

スケジューラを使用すると、Report Writer および Usage Import でタスクの一部を、自動的に実行できます。これによって、システム資源の最適化や、定期的なタスクの実行を自動化できます。たとえば、午前 2 時から 4 時までの間にサイトが比較的すいている場合は、この時間帯にデータベースを最適化できます。また、運用マネージャが毎朝 8 時に、前日のサイト全体の利用状況レポートを見ることになっている場合は、これらのタスクを自動化できます。

スケジューラの操作は、ジョブをスケジュールし、そのジョブにタスクを追加するという 2 つの手順から構成されます。ジョブは、指定したスケジュールに従って実行され、ジョブのタスクは、スケジューラに表示される順序で先頭のタスクから実行されます。一般的なジョブの例を次に示します。


ジョブをスケジュールする

ジョブをスケジュールするには、ジョブを実行する日時を選ぶことによって、ジョブのスケジュールを指定します。新規ジョブをスケジュールするときに、その日時に既に別のジョブがスケジュールされていると、ジョブが干渉し合う可能性があることを示すメッセージが表示されます。その場合は、ジョブが重複しないように、どちらかのスケジュールを変更することをお勧めします。ジョブが重複するのを避けるには、同じ日に実行するタスクを 1 つのジョブにまとめます。

ジョブをスケジュールしたら、アクティブ化するかどうかを選びます。アクティブ化するかどうかが選択できるので、ジョブを削除したりスケジュールを変更したりせずに、ジョブを実行するかどうかを選択できます。たとえば、休日で要求が少ない場合は、インポートをスキップできます。

ジョブが実行されると、各タスクの結果を示すメッセージが、uimport.log というメッセージ ログ ファイルに自動的に保存されます。ジョブが複数ある場合は、ジョブが実行されるたびに、メッセージ ログ ファイルの最後に新しいメッセージが追加されます。ジョブごとに、別のメッセージ ログ ファイルを作成することもできます。また、日付変数を使用すると、実行されるジョブを特定のメッセージ ログ ファイルに関連付けることができます。

わかりやすいように、ジョブの名前を変更することもできます。

ジョブをスケジュールし、目的のタスクを追加してから、スケジューラを閉じると、バッチ ファイルが作成されます。このバッチ ファイルには、ジョブのタスクを実行する一連のオペレーティング システム コマンドが入っています。ジョブは、バッチ ファイルのコマンドに従って実行されます。バッチ ファイルは、Program Files\Microsoft Site Server Express\Data\Analysis\Schedule ディレクトリに格納されます。ジョブのバッチ ファイルを編集して、オペレーティング システム コマンドを追加すると、スケジューラでは作成されないタスクも実行できます。

関連項目

  • 日付変数を使用する


ジョブをスケジュールするには

  1. Usage Import または Report Writer を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. ジョブ アイコンを右クリックし、[新規ジョブ] をクリックします。
  3. [実行日] の [今日]、[明日]、[毎]、[次] のいずれかをクリックします。

    [今日] または [明日] をクリックした場合は、ジョブは 1 回だけ実行されます。[毎] または [次] をクリックした場合は、[日] ボックスの一覧で、ジョブを起動する日をクリックします。

  4. [時刻] ボックスに、ジョブを起動する時刻を入力します。「11:00:00 午前」や「2:00:00 午後」のように、12 時間形式で指定します。
  5. ジョブをアクティブ化するには、[アクティブ] チェック ボックスをオンにします。
  6. ジョブのそれぞれのメッセｰジ ログ ファイルを作成するには、[メッセージ ログ] タブをクリックし、[メッセージ ログ] ボックスに、メッセージ ログ ファイルのパスとファイル名を入力します。

    パスとファイル名を設定しない場合、ジョブの実行結果は自動的に uimport.log というメッセｰジ ログ ファイルに追加されます。ファイル名に日付変数を使う場合は、[ファイル名に日付変数を使用できます (オプション)] ボックスの一覧で、対象の変数を選択できます。

  7. [OK] をクリックします。

    必要なタスクをジョブに追加します。

関連項目

  • Usage Import を起動するには
  • Report Writer を起動するには
  • 日付変数を使用する
  • ジョブにタスクを追加する


ジョブにタスクを追加する

ジョブに追加できるタスクは、次のとおりです。

  • ログ ファイル インポート。
  • IP アドレスの解決。
  • Whois 検索を実行する。
  • HTML タイトル検索の実行。
  • レポートの実行。
  • 要求の削除。
  • データベースの最適化。

複数のタスクを追加できます。たとえば、レポートを作成する 3 つのタスクをまとめて、1 つのジョブにすることもできます。

わかりやすいように、タスクの名前を変更することもできます。

タスクの実行順序を指定する

ジョブに追加するタスクは自由に組み合わせられますが、実行順序は重要です。たとえば、ログ ファイルをインポートしてからレポートを作成すると、レポートにサイトの最新データを反映できます。インポート後に、IP アドレスの解決と Whois 検索を実行してからレポートを作成すると、さらに豊富なデータを反映できます。

新規ジョブ (それまでのスケジューラ セッションでタスクを追加したことがないジョブ) にタスクを追加した場合は、タスクは指定した順序で実行されます。既存のジョブの場合は、タスクはジョブの最後に追加されます。既存のジョブのタスク実行順序を変更するには、ジョブのバッチ ファイルを編集します。

注

切り取り、コピー、および貼り付けを使用してスケジューラ内でタスクの配置を変更しても、タスクの実行順序は変わりません。


ログ ファイル インポートをスケジュールするには

タスクを新規ジョブに追加する場合は、次の手順で行います。タスクを既存のジョブに追加する場合は、この手順でタスクを追加してから、必要に応じてバッチ ファイルを編集して実行順序を変更します。

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. ジョブをスケジュールします。
  3. タスクを追加するには、ジョブ アイコンかタスク アイコンを右クリックし、新規タスクをクリックします。タスクは追加された順序で実行されます。
  4. [タスクの種類] ボックスの一覧で、[ログ ファイル インポート] をクリックします。
  5. [ログ データ ソース] ボックスの一覧で、ログ ファイルが関連付けられたログ データ ソースをクリックします。
  6. [アクセス] ボックスの一覧で、ログ アクセスの種類をクリックします。[file://] を選択した場合は、[参照] をクリックして、ログ ファイルがあるディレクトリを探し、インポートするログ ファイルを選択します。[ftp://] を選択した場合は、[ログイン] をクリックして、FTP 接続のログイン情報とインポートするログ ファイルを指定します。[ODBC] を選択した場合は、[ログイン] をクリックして、ODBC (Microsoft® Open Database Connectivity) データベースにログイン情報を反映し、インポートするログ テーブルを指定します。
  7. [ログ パス] ボックスに、選択したログ ファイルまたはログ テーブルが表示されます。ファイル名に日付変数を使う場合は、[ファイル名に日付変数を使用できます (オプション)] ボックスで、対象の変数を選択できます。
  8. [一覧に追加する] をクリックし、[OK] をクリックします。

    タスクがジョブの下に表示されます。スケジュールするタスクがほかになければ、スケジューラを閉じます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには
  • 既存のジョブのタスク実行順序を変更するには
  • ジョブをスケジュールする
  • インポート プロセスを管理する
  • FTP サーバーからログ ファイルをインポートするには
  • ODBC データベースからインポートする
  • 日付変数を使用する


IP アドレスの解決をスケジュールするには

タスクを新規ジョブに追加する場合は、次の手順で行います。タスクを既存のジョブに追加する場合は、この手順でタスクを追加してから、必要に応じてバッチ ファイルを編集して実行順序を変更します。

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. ジョブをスケジュールします。
  3. タスクを追加するには、ジョブ アイコンかタスク アイコンを右クリックし、新規タスクをクリックします。タスクは追加された順序で実行されます。
  4. [タスクの種類] ボックスの一覧で、[IP アドレスの解決] をクリックします。
  5. [OK] をクリックします。

    タスクがジョブの下に表示されます。スケジュールするタスクがほかになければ、スケジューラを閉じます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには
  • 既存のジョブのタスク実行順序を変更するには
  • ジョブをスケジュールする
  • データベース中のデータの品質を高める


Whois 検索の実行をスケジュールするには

タスクを新規ジョブに追加する場合は、次の手順で行います。タスクを既存のジョブに追加する場合は、この手順でタスクを追加してから、必要に応じて実行順序を変更します。

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. ジョブをスケジュールします。
  3. タスクを追加するには、ジョブ アイコンかタスク アイコンを右クリックし、新規タスクをクリックします。タスクは追加された順序で実行されます。
  4. [タスクの種類] ボックスの一覧で、[Whois 検索を実行する] をクリックします。
  5. [OK] をクリックします。

    タスクがジョブの下に表示されます。スケジュールするタスクがほかになければ、スケジューラを閉じます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには
  • 既存のジョブのタスク実行順序を変更するには
  • ジョブをスケジュールする
  • データベース中のデータの品質を高める


HTML タイトル検索の実行をスケジュールするには

タスクを新規ジョブに追加する場合は、次の手順で行います。タスクを既存のジョブに追加する場合は、この手順でタスクを追加してから、必要に応じてバッチ ファイルを編集して実行順序を変更します。

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. ジョブをスケジュールします。
  3. タスクを追加するには、ジョブ アイコンかタスク アイコンを右クリックし、新規タスクをクリックします。タスクは追加された順序で実行されます。
  4. [タスクの種類] ボックスの一覧で、[HTML タイトル検索の実行] をクリックします。
  5. デフォルトのフィルタ (タイトル="") を変更することや、フィルタを追加することもできます。
  6. [OK] をクリックします。

    タスクがジョブの下に表示されます。スケジュールするタスクがほかになければ、スケジューラを閉じます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには
  • 既存のジョブのタスク実行順序を変更するには
  • ジョブをスケジュールする
  • データベース中のデータの品質を高める


レポートの実行をスケジュールするには

タスクを新規ジョブに追加する場合は、次の手順で行います。タスクを既存のジョブに追加する場合は、この手順でタスクを追加してから、必要に応じてバッチ ファイルを編集して実行順序を変更します。

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. ジョブをスケジュールします。
  3. タスクを追加するには、ジョブ アイコンかタスク アイコンを右クリックし、新規タスクをクリックします。タスクは追加された順序で実行されます。
  4. [タスクの種類] ボックスの一覧で、[レポートの実行] をクリックします。
  5. [定義ファイル] ボックスに、実行するレポート定義のパスとファイル名を入力します。ファイルを探すには、[参照] をクリックします。
  6. [ドキュメント ファイル] ボックスに、レポート ファイル名を入力します。ファイル名に日付変数を使う場合は、[ファイル名に日付変数を使用できます (オプション)] ボックスで、対象の変数を選択できます。
  7. [OK] をクリックします。

    タスクがジョブの下に表示されます。スケジュールするタスクがほかになければ、スケジューラを閉じます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには
  • 既存のジョブのタスク実行順序を変更するには
  • ジョブをスケジュールする
  • レポート定義を選択する
  • 日付変数を使用する
  • レポートを配布する


要求の削除をスケジュールするには

タスクを新規ジョブに追加する場合は、次の手順で行います。タスクを既存のジョブに追加する場合は、この手順でタスクを追加してから、必要に応じてバッチ ファイルを編集して実行順序を変更します。

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. ジョブをスケジュールします。
  3. タスクを追加するには、ジョブ アイコンかタスク アイコンを右クリックし、新規タスクをクリックします。タスクは追加された順序で実行されます。
  4. [タスクの種類] ボックスの一覧で、[要求の削除] をクリックし、[ディメンジョン] ボックスで、フィルタ名として追加するディメンジョンを入力またはクリックします。
  5. [条件] ボックスで、使用する演算子を入力またはクリックし、[値] ボックスで、フィルタに使用する値を入力またはクリックします。
  6. [追加] をクリックします。

    [ブール式フィルタと一致する要求を削除する] ボックスに、フル フィルタが表示されます。フィルタをさらに追加する場合は、手順 4. から 6. を繰り返します。フィルタが複数の場合は、"AND" または "OR" で区切ります。

  7. [OK] をクリックします。

    タスクがジョブの下に表示されます。スケジュールするタスクがほかになければ、スケジューラを閉じます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには
  • 既存のジョブのタスク実行順序を変更するには
  • ジョブをスケジュールする
  • インポート済みのログ ファイルを管理する


データベースの最適化をスケジュールするには

タスクを新規ジョブに追加する場合は、次の手順で行います。タスクを既存のジョブに追加する場合は、この手順でタスクを追加してから、必要に応じてバッチ ファイルを編集して実行順序を変更します。

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. ジョブをスケジュールします。
  3. タスクを追加するには、ジョブ アイコンかタスク アイコンを右クリックし、新規タスクをクリックします。タスクは追加された順序で実行されます。
  4. [タスクの種類] ボックスの一覧で、[データベースの最適化] をクリックします。
  5. [ソース データベース] ボックスに、圧縮するデータベースのパスとファイル名を入力します。データベースを探すには、[参照] をクリックします。
  6. [OK] をクリックします。

    タスクがジョブの下に表示されます。スケジュールするタスクがほかになければ、スケジューラを閉じます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには
  • 既存のジョブのタスク実行順序を変更するには
  • ジョブをスケジュールする
  • データベースを圧縮する


既存のジョブのタスク実行順序を変更するには

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。

    スケジューラが開いている場合は、手順 2. を行う前に、いったんスケジューラを閉じてから再起動します。

  2. 変更するジョブを右クリックし、[バッチ ファイルの編集] をクリックします。[はい] をクリックして確認します。
  3. ドラッグ アンド ドロップの操作を使用してバッチ ファイルを編集し、実行する順序にタスクを並べ替えます。

    バッチ ファイルは、タスクごとにコメント行 ("REM") で区切られています。

  4. スケジューラを閉じます。
  5. バッチ ファイルを、保存してから閉じます。

    もう一度スケジューラを開くと、タスクがバッチ ファイルで指定した順序で表示されます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには


ジョブやタスクの名前を変更するには

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。
  2. 名前を変更するジョブまたはタスクをクリックします。
  3. 新しい名前を入力し、Enter キーを押します。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには


日付変数を使用する

日付変数は、ログ ファイルのインポートやレポートの作成のタスクで使用できます。また、ジョブのメッセージ ログ ファイルにも使用できます。ログ ファイルのインポートに日付変数を使用すると、インポートするファイルを識別する手順を自動化できます。レポートのタスクや、ジョブのメッセージ ログ ファイルで使用すると、レポートやメッセージ ログ ファイルを作成した日付が、ファイル名から識別できます。

日付変数をログ ファイルのインポートに使用するときは、インポートするファイルに使用する名前と日付の規則に合わせて指定します。たとえば、サーバーはログ ファイルを交換するときに、ログ ファイルのファイル名に、一定のファイル命名規則に従って日付を入れ、その日付でファイルを識別します。したがって、Microsoft® W3C 拡張ログ ファイル形式を使用し、ログ ファイルを毎日交換する場合は、ファイル名は exyymmdd.log という形式になります。ex はログ ファイルの形式を、yymmdd は作成された年月日を表します。このログ ファイルを、交換した次の日に日付変数を使用してインポートするには、ログ ファイルをインポートするタスクを追加し、インポートするログ ファイルを ex$1.log と指定します。

ログ ファイルの交換と命名については、Web サーバーのマニュアルを参照してください。

次の表は、日付変数と、置換後の形式を表します。

日付変数 | 形式 (サンプルまたは範囲)
$1 | 前日の年月日。"971013" は 1997 年 10 月 13 日を表します。
$A | 曜日 ("火曜日")。
$a | 曜日の省略形 ("Tue")。
$B | 月 ("10 月")。
$d | 日 ("01" ～ "31")。
$e | 日 ("1" ～ "31") 。1 桁の場合、1 文字目は空白 ("2")。
$H | 時 ("08")。
$I | 時 ("00" ～ "23")。24 時間形式。
$j | 日 ("287")。その年の何日目かを示す。
$k | 時 ("8")。
$l | 時 ("1" ～ "12")。12 時間形式。1 桁の場合、1 文字目は空白 ("2")。
$M | 分 ("00" ～ "59")。
$m | 月 ("1" ～ "12")。
$p | "A.M." または "P.M."。
$S | 秒 ("00" ～ "59")。
$s | 秒数。1970 年 1 月 1 日、午後 4:00 からの秒数を示します。
$U | 週 ("1" ～ "53")。その年の何週目かを示します。
$W | 週 ("0" ～ "6")。その月の何週目かを示します。
$w | 曜日 ("0" ～ "6")。
$Y | 年 ("1997")。


スケジューラを実行するアカウントを変更する

スケジュールしたジョブは、スケジューラ サービスと同じアカウントで実行されます。デフォルトでは、スケジューラ サービスはローカルなシステム アカウントで実行されます。ローカルなシステム アカウントは、一般的に権限が非常に限られています。そのため、手動では成功するタスクが、スケジュールして実行すると失敗する場合があります。失敗するおそれのあるタスクは主に、リモート システムへのアクセスを伴うタスクです。この問題を解決するには、スケジューラを実行するアカウントを変更する必要があります。

スケジューラ サービスについては、Microsoft® Windows NT® のマニュアルを参照してください。


スケジューラを実行するアカウントを変更するには

  1. デスクトップの [マイ コンピュータ] をダブルクリックし、[タスク] をダブルクリックします。
  2. [詳細設定] メニューの [AT サービス アカウント] をクリックします。
  3. [AT サービス アカウントの構成] ダイアログ ボックスの [このアカウント] をクリックします。
  4. [このアカウント] ボックスに、 スケジュールしたタスクを実行する権限を持つ Windows NT アカウント名を入力します。[パスワード] ボックスに、アカウント名に対応するパスワードを入力します。[パスワードの確認入力] ボックスに、確認のためにパスワードを再入力し、[OK] をクリックします。

関連項目

  • スケジューラを実行するアカウントを変更する


レポートを配布する

レポートは、レポートを作成するコンピュータに格納されます。レポートを自動的に配布するには、次の方法のいずれかを実行します。

  • レポートを、リモート コンピュータのディレクトリに格納します。ただし、この方法を実行するには、スケジューラを実行するアカウントを変更する必要がある場合があります。
  • ジョブのバッチ ファイルを編集し、HTML レポートを外部の Web サーバーにポストするように変更します。

関連項目

  • スケジューラを実行するアカウントを変更する


レポートを Web サーバーにポストするには

  1. レポート作成タスクをジョブに追加するときに、レポートをすべて同じディレクトリに保存します。このディレクトリには、レポート ファイルだけを保存します。
  2. ユーザー名、パスワード、およびパス情報を記述した、次のようなコマンド ライン FTP スクリプトを作成します。
    user username password
lcd C:\Progra~1\Usagea~1\Reports
cd /web/hthome/reports
bin
prompt
mput *.htm *.jpg
bye

  3. このコマンド ライン FTP スクリプトを実行するように、バッチ ファイルを変更します。

    4.

関連項目

  • レポートを配布する

    •


バッチ ファイルを編集する

オペレーティング システム コマンドをジョブに追加して、スケジューラが作成しないタスクを実行するには、バッチ ファイルを編集します。たとえば、あるコンピュータのログ ファイルを別のコンピュータにコピーするタスクや、完成したレポートを電子メールで配布リスト上のアドレスに送信するタスクが追加できます。バッチ ファイルは、スケジューラを閉じたときに作成されます。このため、作成したばかりのジョブのバッチ ファイルを編集するには、いったんスケジューラを閉じてから開き直す必要があります。たとえば、あるコンピュータのログ ファイルを別のコンピュータにコピーするタスクや、完成したレポートを電子メールで配布リスト上のアドレスに送信するタスクが追加できます。バッチ ファイルは、スケジューラを閉じたときに作成されます。このため、作成したばかりのジョブのバッチ ファイルを編集するには、いったんスケジューラを閉じてから開き直す必要があります。

スケジューラが作成しないバッチ ファイル コマンドについては、Windows NT オペレーティング システムのマニュアルを参照してください。

関連項目

  • バッチ ファイルのサンプル


バッチ ファイルを編集するには

  1. Report Writer または Usage Import を起動し、[ツール] メニューの [スケジューラ] をクリックします。

    スケジューラが開いている場合は、手順 2. を行う前に、いったんスケジューラを閉じてから再起動します。

  2. 編集するバッチ ファイルのジョブを右クリックし、[バッチ ファイルの編集] をクリックします。
  3. [はい] をクリックして確認します。
  4. 必要な変更を行います。
  5. バッチ ファイルを保存して閉じる前に、スケジューラを閉じます。
  6. バッチ ファイルを保存してから閉じます。

    もう一度スケジューラを開くと、バッチ ファイルで編集した内容がタスクの表示に反映されます。

関連項目

  • Report Writer を起動するには
  • Usage Import を起動するには
  • バッチ ファイルを編集する


バッチ ファイルのサンプル

バッチ ファイルのサンプルを、次に示します。先頭に "REM" が付いている行は、コメントです。始めの部分で、ジョブを実行する日時と、ジョブ実行時にアクセスするプログラム (Usage Import または Report Writer) を設定し、その後、1 つのジョブで 1 タスクずつ実行しています。

REM START DO NOT MODIFY
REM SCHEDULER BATCH FILE-- DO NOT MODIFY IN
REM BETWEEN COMMENTS
REM CREATED 8/7/98 3:00:26 PM
REM ACTIVE True
REM JOBID 1
REM OCCURS 2
REM DAYS 0 and 1 and 2 and 3 and 4 and 5 and 6
REM TIME 12:00:00 AM
SET UIMPORT="E:\Program Files\Microsoft Site Server Express\Bin\UImport.exe"
SET REPORT="E:\Program Files\Microsoft Site Server Express\Bin\Report.exe"
REM END DO NOT MODIFY

REM START DO NOT MODIFY
REM TASK "ログ ファイル インポート"
%UIMPORT% -silence messagelog="Mymessage" db="E:\Program Files\Microsoft Site Server Express\Data\MsUsage.mdb" source="Log data source:E:\winnt\system32\logfiles\w3svc1\Ex$1.log"
REM END DO NOT MODIFY

REM START DO NOT MODIFY
REM TASK "IP アドレスの解決"
%UIMPORT% -silence messagelog="Mymessage" db="E:\Program Files\Microsoft Site Server Express\Data\MsUsage.mdb" action="IP resolution"REM END DO NOT MODIFY

REM START DO NOT MODIFY
REM TASK "Whois 検索を実行する"
%UIMPORT% -silence messagelog="Mymessage" db="E:\Program Files\Microsoft Site Server Express\Data\MsUsage.mdb" action="WhoIs"
REM END DO NOT MODIFY

REM START DO NOT MODIFY
REM TASK "HTML タイトル検索の実行"
%UIMPORT% -silence messagelog="Mymessage" db="E:\Program Files\Microsoft Site Server Express\Data\MsUsage.mdb" titles='(タイトル = "")'
REM END DO NOT MODIFY

REM START DO NOT MODIFY
REM TASK "レポートの実行"
%REPORT% -silence messagelog="Mymessage" db="E:\Program Files\Microsoft Site Server Express\Data\MsUsage.mdb" report="E:\Program Files\Microsoft Site Server Express\Bin\$1.htm" reportdef="E:\Program Files\Microsoft Site Server Express\Bin\Catalog\summary\executivesummary.mfa"
REM END DO NOT MODIFY

REM START DO NOT MODIFY
REM TASK "要求の削除"
%UIMPORT% -silence messagelog="Mymessage" db="E:\Program Files\Microsoft Site Server Express\Data\MsUsage.mdb" delete='(日付 < "10/31/97")'
REM END DO NOT MODIFY

REM START DO NOT MODIFY
REM TASK "データベースの最適化"
%UIMPORT% -silence messagelog="Mymessage" sourcedb="E:\Program Files\Microsoft Site Server Express\Data\Msusage.mdb"
REM END DO NOT MODIFY


ご注意

  1. このソフトウェアの著作権は、米国 Microsoft Corporation にあります。
  2. このソフトウェアおよびマニュアルの一部または全部を無断で使用、複製することはできません。
  3. ソフトウェアは、コンピュータ 1 台につき 1 セット購入が原則となっております。
  4. このソフトウェアおよびマニュアルは、本製品の使用許諾契約書のもとでのみ使用することができます。
  5. このソフトウェアおよびマニュアルを運用した結果の影響については、いっさい責任を負いかねますのでご了承ください。
  6. マイクロソフトは、このマニュアルに記載される内容に関し、特許、特許申請、商標、著作権、またはその他の無形財産件を有する場合があります。このマニュアルは、これらの特許、商標、著作権またはその他の無形財産権に関する権利をお客様に許諾するものではありません。
  7. このソフトウェアの仕様、およびマニュアルに記載されている事柄は、将来予告なしに変更することがあります。

サンプル アプリケーションで使用している名称は、すべて架空のものです。実在する商品名、団体名、個人名とは一切関係がありません。

© 1997-1998 Microsoft Corporation. All rights reserved.

Microsoft、MS-DOS、MS、Windows、Windows NT、Win32、Win32s、Microsoft At Work、ActiveX、BackOffice、Front Page、JScript、Netshow、Outlook、Microsoft Press、Visual Basic、Visual C++、Visual J++、Visual InterDev、Visual SourceSafe、および MSN は、米国 Microsoft Corporation の米国およびその他の国における登録商標または商標です。

その他記載されている会社名、製品名は、各社の商標および登録商標です。


Microsoft Site Server Posting Acceptor マニュアル

Posting Acceptor マニュアル

Posting Acceptor マニュアルは、サイト上で Posting Acceptor を設定する作業の概要と手順について説明しています。マニュアルの構成は、次のとおりです。

  • 「コンテンツのアップロードを許可する」。Posting Acceptor のインストール、設定、操作方法について説明します。


Microsoft Site Server Express Analysis

Analysis マニュアル

Analysis マニュアルは、サイト上で Analysis を使用する作業の概要と手順について説明しています。マニュアルの構成は、次のとおりです。

  • 「Usage Import」。ログ ファイルをインポートする前に実行する手順、データのインポート方法を制御しカスタマイズするためのオプション、およびログ ファイルのインポート方法について説明します。
  • 「Report Writer」。レポート定義の選択方法と、レポートの作成方法について説明します。
  • 「Analysis データベースの管理」。データベースのパフォーマンスの最適化、新規データベースの作成、ほかのデータベースとの接続、およびデータベースの内容の表示について説明します。
  • 「アクティビティのスケジュール」。Report Writer と Usage Import で自動実行化できるタスクについて説明します。


Microsoft Site Server Express

Microsoft® Site Server Express は、Web サイトの利用状況の分析作業を補助します。 Site Server Express の機能は、Microsoft® Site Server と Microsoft® Site Server, Commerce Edition の機能のサブセットです。Site Server は、ネットワーク上で情報をすばやく簡単に配信し収集するための、強力なイントラネット サーバーです。Site Server, Commerce Edition は、オンライン ビジネスを運営するための、包括的なインターネット サーバーです。

Site Server Express の Web 分析機能を使うと、Microsoft® Windows NT®/Microsoft® Internet Information Server (IIS) Web サイトを簡単に管理できます。 Site Server Express を使うことにより、Web サイトのトラフィックを分析し、さまざまなレポートをすばやく簡単に作成できます。

Web の利用状況の分析

Usage Import と Report Writer を使うと、1 台のサーバーの IIS ログ ファイルを収集し、分析することができます。 定義済みのさまざまなレポートを利用し、サイトへの要求や、サイトを実際に利用しているユーザーや組織の情報を把握することができます。これらの情報を抽出することにより、Web の利用にどのような傾向があるかを調べたり、ビジネス上の判断をより的確に行うための有益な情報を入手できます。

Usage Import と Report Writer の詳細については、「Analysis マニュアル」を参照してください。


[Report Writer オプション] ダイアログ ボックスの [出力先フォルダ] タブ

このタブを使用して、レポート ファイルとレポート定義ファイルをそれぞれ格納するデフォルトのフォルダを指定します。このデフォルト設定は、レポートを生成したり、レポート定義を保存するときにも変更できます。

このタブの設定は全レポートに適用されるもので、いつでも変更できます。Report Writer を起動すると、設定はすべてデフォルトに戻ります。現在の設定をデフォルト設定にするには、[この設定を保存] をクリックします。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • デフォルトの保存先フォルダを選択する


[Report Writer オプション] ダイアログ ボックスの [計算キャッシュ] タブ

このタブを使用して、Report Writer で計算をキャッシュするかどうかを指示し、キャッシュのフォルダと最大サイズを指定します。

計算をキャッシュすると、計算結果はすべて指定したフォルダのファイルに格納されます。同じ計算を行う全レポートでこのファイルが使用されるため、レポートの作成時間が短縮されます。インポートしたログ ファイルに、このキャッシュ ファイルのデータと矛盾するデータが入っていると、キャッシュ ファイルがクリアされます。

指定したフォルダにあるキャッシュ ファイルをすべて削除するには、[キャッシュのクリア] をクリックします。

このタブの設定は全レポートに適用されるもので、いつでも変更できます。Report Writer を起動すると、設定はすべてデフォルトに戻ります。現在の設定をデフォルト設定にするには、[この設定を保存] をクリックします。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。


[Report Writer オプション] ダイアログ ボックスの [レポート コンテンツ] タブ

このタブを使用して、レポートの下に一般的な用語 (ヒット、訪問、要求など) の定義を入れるかどうかと、グラフに純色またはパターン ラインの陰影を付けるかどうかを指定します。また、HTML イメージ ソース ファイル名を、小文字だけ、大文字だけ、または大文字と小文字の混在のうち、どの方法で参照するかも指定します。

このタブの設定は全レポートに適用されるもので、いつでも変更できます。Report Writer を起動すると、設定はすべてデフォルトに戻ります。現在の設定をデフォルト設定にするには、[この設定を保存] をクリックします。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。


[Report Writer オプション] ダイアログ ボックスの [レポート プレゼンテーション] タブ

このタブを使用して、レポート ヘッダー テキストの表示形式と、レポートの背景色を変更します。レポート ヘッダー テキストは、レポートの先頭の、レポート タイトルとレポートの説明のすぐ下に表示されます。レポート ヘッダー テキストには、分析の日時、分析したインターネット サイト、最初と最後の要求の日付などの情報が含まれます。

このタブの設定は全レポートに適用されるもので、いつでも変更できます。Report Writer を起動すると、設定はすべてデフォルトに戻ります。現在の設定をデフォルト設定にするには、[この設定を保存] をクリックします。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • レポート ヘッダーの分析情報セクションを編集するには


[レポート ドキュメント] ダイアログ ボックス

このダイアログ ボックスを使用して、レポートのファイル名と形式を指定します。形式は、HTML、Microsoft® Word、Microsoft® Excel のいずれかです。

レポートに使用する既存のテンプレートを選択するには、このバージョンの Microsoft® Site Server Express では、テンプレートを作成することはできません。

レポートを作成するには、[OK] をクリックします。

HTML 形式を選択すると、完成したレポートはブラウザのウィンドウに表示されます。Word 形式か Excel 形式を選択すると、完成したレポートは対応するアプリケーションのウィンドウに表示されます。

レポートの作成が完了すると、統計情報には各計算の所要時間が表示されます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • Report Writer カタログからレポートを実行する


計算に関するプロパティのダイアログ ボックスの [説明] タブ

このタブを使用して、計算の説明を指定または変更します。計算の説明は、計算のプレゼンテーションの上に表示されます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • セクションまたは計算のヘッダーを編集する


計算に関するプロパティのダイアログ ボックスの [ヘッダーの表示設定] タブ

このタブを使用して、計算ヘッダーの表示形式を変更します。計算のヘッダーには、計算名と計算の説明があり、計算のテーブルやグラフの直前に表示されます。

計算名の表示形式を変更するには、タブ上部にある [計算名] をクリックします。計算名を表示するには、[テーブルのセルのプロパティ] の [可視] チェック ボックスをオンにします。背景色は [色] で選択します。計算名ボックスの周りにグリッド ラインを表示するには、[テーブルのグリッド ライン] の [可視] チェック ボックスをオンにします。[テキストのプロパティ] では、計算名のフォントの種類、サイズ、および色も変更できます。

計算の説明の表示形式を変更するには、タブの上部で [計算の説明] をクリックします。計算の説明を表示するには、[テーブルのセルのプロパティ] の [可視] チェック ボックスをオンにします。背景色は [色] で選択します。解説のボックスの周りにグリッド ラインを表示するには、[テーブルのグリッド ライン] の [可視] チェック ボックスをオンにします。[テキストのプロパティ] では、計算の説明のフォントの種類、サイズ、および色も変更できます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • セクションまたは計算のヘッダーを編集する


[要求の削除] ダイアログ ボックス

このダイアログ ボックスを使用して、削除する要求を識別するフィルタを指定します。[削除] をクリックすると、指定したフィルタと一致する要求がデータベースから削除されます。

フィルタは、ディメンジョン、演算子、および値の 3 要素を、"<ディメンジョン><演算子><値>" という構文で表したものです。たとえば、(日付 = 98/07/14) というフィルタは、"日付" ディメンジョン、= 演算子、および 98/07/14 という値を表します。

フィルタを追加するには、[ディメンジョン] ボックスを選択し、[条件] ボックスの一覧から適切な値を選択し、[値] ボックスで値を入力します。式を確認して [追加] をクリックします。式を and や or で区切って並べると、複雑なフィルタも作成できます。たとえば、1998 年 7 月の 4 日から 8 日までに発生した要求を削除するには、(日付 >= 98/07/04) AND (日付 <= 98/07/08) というフィルタを使用します。

注

削除したデータを復元するには、Usage Import を使用してインポートしたデータをすべて削除し、データをもう一度インポートしてください。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の Help icon をクリックし、そのオプションをクリックします。

関連項目

  • 要求を削除するには
  • インポート済みのログ ファイルを管理する


[ディメンジョン プロパティ] ダイアログ ボックスの [詳細] タブ

このタブを使用して、ディメンジョンの結果の制限と、ソート順を指定します。また、プレゼンテーションがテーブルなら、要約情報を追加するかどうかも、ここで指定します。

ディメンジョンの結果は、一定の項目数に制限したり、項目の総数に対して一定のパーセンテージに制限できます。プレゼンテーションに、項目数またはパーセンテージの上位か下位を含めるかどうかを決定します。まず、[結果の最大数] ボックスの一覧で [上位] または [下位] をクリックします。結果を制限しない場合は、[すべて] をクリックします。右側のボックスに、項目数かパーセンテージを整数で指定します。右端のボックスの一覧で、[項目] または [パーセント] を選択します。

テーブルやグラフへの結果のプレゼンテーション順序は、[並べ替え] ボックスの一覧で [最初のメジャー] または [ディメンジョン] を選択します。たとえば、行のディメンジョンが [日付]、メジャーが [帯域幅 (MB)] の棒グラフでは、[ディメンジョン] を選択すると、横軸には日付が日付順に (左から右に) 並びます。また、[最初のメジャー] を選択すると、帯域幅を表す棒グラフは降順に表示され、横軸には日付が帯域幅順に並びます。

[要約] ボックスの一覧で指定するオプションは、テーブルのプレゼンテーションだけに適用されます。テーブルのメジャーに、詳細値のほかに要約情報も追加するには、このボックスで要約のオプションを選択します。テーブルの行か列に、選択した要約 ([なし]、[合計]、[最小値]、[最大値]、[平均値]、および [メジアン]) が表示されます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の Help icon をクリックし、そのオプションをクリックします。

関連項目

  • ディメンジョンおよびメジャーについて
  • ディメンジョン リファレンス ガイド


[FTP URL プロパティ] ダイアログ ボックス

このダイアログ ボックスを使用して、FTP サーバーへの接続に必要なパラメータと、FTP 接続を使ってインポートするログ ファイルを指定します。

[ホスト名] ボックスに FTP サーバーのホスト名を、[ユーザー名] ボックスにユーザー名を、[パスワード] ボックスにパスワードをそれぞれ入力します。[ファイル名 (フル パス) が必要です。)] ボックスに、リモート サーバーにあるログ ファイルのパスとファイル名を入力します。インポートするログ ファイル一覧にこのファイルを追加するには、[OK] をクリックしてから、[インポート マネージャ] ダイアログボックスの [追加] をクリックします。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • FTP サーバーからログ ファイルをインポートするには
  • ログ ファイルをインポートする


[インポート履歴の詳細] ダイアログ ボックス

このダイアログ ボックスを使用して、選択したインポートを構成するログ ファイルを一覧表示します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • インポート済みのログ ファイルを管理する


[インポート オプション] ダイアログ ボックスの [ログ ディレクトリ] タブ

このタブを使用して、通常、ログ ファイルが存在するディレクトリを指定します。デフォルトのディレクトリを指定しておくと、インポート マネージャでログ ファイルを簡単に指定できます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • ログ ファイルのデフォルト ディレクトリを指定する


[インポート オプション] ダイアログ ボックスの [サーバー] タブ

ローカル エリア ネットワーク (LAN) のプロキシ サーバーを通じてインターネットに接続している場合に、IP 解決、HTML タイトル検索、Whois 検索、または FTP サーバーからのインポートを実行するときには、このタブを使用して、インターネットへのアクセス方法を指定します。

HTML タイトル検索を実行するときは、HTTP プロキシ サーバーのアドレスを、[HTTP プロキシ] ボックスに入力します。プロキシ サーバーにユーザー名とパスワードを渡す必要があれば、プロキシ ホスト名を、"<ユーザー名>:<パスワード>@<ホスト名>" という構文で入力します。[HTTP ポート] ボックスに、HTTP プロキシ サーバーのポート番号を入力します。

FTP サーバーからログをインポートするときは、[FTP プロキシ] ボックスと [FTP ポート] ボックスに、FTP プロキシ サーバーのアドレスとポート番号を入力します。

IP 解決を実行するときは、[DNS サーバーのローカル ドメイン] ボックスに、ローカルな DNS (Domain Name System) サーバーのドメインを入力します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • インターネットに接続する
  • データベース中のデータの品質を高める


[インポート オプション] ダイアログ ボックスの [クローラ一覧] タブ

このタブを使用して、インターネット検索エンジン、クローラ、およびロボットからの要求を、データベースにインポートしないようにします。[クローラを除外する] チェック ボックスをオンにすると、[クローラ ユーザー エージェント文字列] ボックスに一覧表示されるエージェントからの要求が除外されます。

標準的なクローラは、はじめから一覧に含まれています。ユーザーのエージェント文字列を追加するには、それぞれの文字列を "" で囲み、空白で区切って並べて入力します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • データをインポート対象から除外する


[インポート オプション] ダイアログ ボックスの [イントラネット] タブ

このタブを使用して、インターネット ドメインをデータベースにインポートするときに、どこまで詳細にインポートするかを指定します。インポートするサブドメインのレベル (0、1、または 2) を入力します。1 か 2 を指定すると、ユーザーの要求が発生した場所が細かく分かるので、インポートでイントラネットを区別する必要があれば、この指定を使います。

デフォルトは 0 (ゼロ) です。たとえばインターネット ドメインが microsoft.com なら、この指定では、このドメインだけがインポートされます。また、1 を選択すれば redmond.microsoft.com がインポートされ、2 を選択すれば marketing.redmond.microsoft.com がインポートされます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • インポート時にイントラネットを識別する


[ジョブのプロパティ] ダイアログ ボックスの [スケジュール] タブ

このタブを使用して、新規ジョブのスケジュールを設定するか、既存のジョブのスケジュールを変更します。[実行日] ボックスで、ジョブを実行する間隔を選択します。[毎] か [次] を選択した場合は、曜日または日 (月の何日目か) を、[日] で選択します。[時刻] ボックスに、ジョブの開始時刻を入力します。たとえば、24 時間形式で「23:30:00」と入力し、[OK] をクリックすると、"11:30:00 午後" という 12 時間形式に変換されます。

[アクティブ] チェック ボックスをオンにすると、次の予定時刻にジョブを実行するようにセットアップされます。ジョブの実行を延期するには、[アクティブ] チェック ボックスをオフにします。

ジョブのタスクが 1 つもセットアップされていない場合は、スケジューラは何も実行しません。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • ジョブをスケジュールする
  • ジョブにタスクを追加する
  • アクティビティのスケジュール


[ジョブのプロパティ] ダイアログ ボックスの [メッセージ ログ] タブ

このタブを使用して、このジョブのメッセージ ログの位置と名前を指定します。メッセージ ログは、メッセージが記録されるテキスト ファイルで、ジョブに関連付けられたタスクが終了するたびに、各タスクの実行結果を表すメッセージが、このファイルに記録されます。

メッセージ ログ ファイルには、ジョブごとに別のファイルを使用することも、全ジョブ共通のファイルを使用することもできます。

メッセージ ログ ファイルは、[メッセージ ログ] ボックスでフォルダとファイル名を入力するか、[参照] をクリックして選択します。ファイル名の一部に日付変数を使用できます。利用できる変数の一覧については、「日付変数を使用する」を参照してください。たとえば、メッセージ ログ ファイル名に「Job3day$j.log」と入力し、ジョブが 2 月 2 日 に実行されるようにスケジュールすると、2 月 2 日 は年の 32 日目なので、使用されるメッセージ ログ ファイルは Job3day32.log という名前になります。

注

メッセージ ログ ファイルを [メッセージ ログ] ボックスで指定しなかった場合は、ファイル名は uimport.log となり、\Program Files\Microsoft Site Server Express\Bin というフォルダに書き込まれます。このフォルダが存在しない場合は、Usage Import のアプリケーション パス ディレクトリに書き込まれます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • ジョブをスケジュールする
  • ジョブにタスクを追加する
  • アクティビティのスケジュール


[ODBC URL プロパティ] ダイアログ ボックス

このダイアログ ボックスを使用して、インポートするログ データが格納されている Microsoft® Open Database Connectivity (ODBC) データベースのテーブルを指定します。

[ODBC DSN] ボックスに、データ ソース名 (DSN) を入力します。[ログ テーブル] ボックスに、データベースがログを収集するテーブル名を入力します。[ユーザー名] ボックスにユーザー名を入力し、必要なら [パスワード] ボックスにパスワードを入力します。インポートするログ ファイル一覧にこのテーブルを追加するには、[OK] をクリックしてから、[インポート マネージャ] ダイアログ ボックスの [追加] をクリックします。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • ODBC データベースからインポートする
  • ログ ファイルをインポートする


レポート プロパティのダイアログ ボックスの [フィルタ] タブ

このタブを使用して、レポート全体に適用するフィルタをビルドします。フィルタは、更新するデータを限定する式です。フィルタを使用すると、たとえば、カナダからの訪問者だけを扱ったレポートを作成できます。

フィルタは、ディメンジョン、演算子、および値の 3 要素を、"<ディメンジョン><演算子><値>" という構文で表した式です。たとえば、(年 = 1997) というフィルタは、"年" ディメンジョン、= 演算子、および 1997 という値を表します。

フィルタを追加するには、[ディメンジョン] ボックスを選択し、[条件] ボックスの一覧から適切な値を選択し、[値] ボックスで値を入力します。式を確認して [追加] をクリックします。たとえば、レポートを [Contest] ページを要求した訪問に限定するには、ディメンジョンに "ファイル名"、演算子に =、値に /contest.html を使用します。

式を and や or で区切って並べると、複雑なフィルタも作成できます。たとえば、午後 8 時 から 11 時の間に発生した要求に関するデータを抽出するには、(時間 >= 20) and (時間 <= 23) というフィルタを使用します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の Help icon をクリックし、そのオプションをクリックします。

関連項目

  • フィルタについて
  • フィルタを追加する
  • フィルタ構造について
  • ディメンジョン リファレンス ガイド


レポート プロパティのダイアログ ボックスの [説明] タブ

このタブを使用して、レポートの解説を指定または変更します。レポートを作成すると、レポート ヘッダーには、レポート定義で解説を隠すようにデフォルトを変更した場合を除いて、レポート解説が表示されます。また、このレポート解説は、Report Writer のカタログからレポートを選択するときにも表示されます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • レポート ヘッダーを編集する


レポート プロパティのダイアログ ボックスの [ヘッダーの表示設定] タブ

このタブを使用して、レポート ヘッダーの表示形式を変更します。

レポート名の表示形式を変更するには、タブの上部で [セクション名] をクリックします。レポート名を表示するには、[テーブルのセルのプロパティ] の [可視] チェック ボックスをオンにします。背景色は [色] で選択します。レポート名ボックスの周囲にグリッド ラインを表示するには、[テーブルのグリッド ライン] の [可視] チェック ボックスをオンにします。セクション名の [テキストのプロパティ] も変更できます。

レポートの説明の表示形式を変更するには、タブ上部の [セクションの説明] をクリックします。説明を表示するには、[テーブルのセルのプロパティ] の [可視] チェック ボックスをオンにします。背景色は [色] で選択します。説明のボックスの周りにグリッド ラインを表示するには、[テーブルのグリッド ライン] の [可視] チェック ボックスをオンにします。[テキストのプロパティ] では、セクションの説明のフォントの種類、サイズ、および色も変更できます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • レポート ヘッダーを編集する


セクションに関するプロパティのダイアログ ボックスの [説明] タブ

このタブを使用して、セクションの説明を入力または変更します。この説明は、生成されたレポートのセクション タイトルの下と、セクションのプレゼンテーションの上に表示されます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の Help icon をクリックし、そのオプションをクリックします。

関連項目

  • セクションまたは計算のヘッダーを編集する


セクションに関するプロパティのダイアログ ボックスの [ヘッダーの表示設定] タブ

このタブを使用して、セクション ヘッダーの表示形式を変更します。セクション ヘッダーは、テーブルやグラフの前に表示されます。

セクション名の表示形式を変更するには、タブ上部の [セクション名] をクリックします。セクション ヘッダーにセクション名を表示するには、[テーブルのセルのプロパティ] の [可視] チェック ボックスをオンにします。背景色は、[色] で選択します。セクション ヘッダーの周囲にグリッド ラインを表示するには、[テーブルのグリッド ライン] の [可視] チェック ボックスをオンにします。[テキストのプロパティ] では、セクション名のフォントの種類、サイズ、および色も変更できます。

セクション ヘッダーのセクションの説明の表示形式を変更するには、タブ上部の [セクションの説明] をクリックします。セクション ヘッダーに説明を表示するには、[テーブルのセルのプロパティ] の [可視] チェック ボックスをオンにします。背景色は、[色] で選択します。セクションの説明ボックスの周りにグリッド ラインを表示するには、[テーブルのグリッド ライン] の [可視] チェック ボックスをオンにします。[テキストのプロパティ] では、セクションの説明のフォントの種類、サイズ、および色も変更できます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • セクションまたは計算のヘッダーを編集する


[ログ ファイル ディレクトリの選択] ダイアログ ボックス

このダイアログ ボックスを使用して、インポートするログ ファイルが格納されているデフォルトのディレクトリを検索し、選択します。デフォルトのディレクトリを設定した後は、インポート マネージャで [参照] をクリックすると、このディレクトリが自動的に選択されます。また、Import Manager の [説明] ボックスでログ ファイル名を指定するときにも、フル パスを指定しなくて済みます。デフォルトでは、C:\Program Files\Microsoft Site Server Express\Data がデフォルトのディレクトリになります。

個別のオプションについては、ダイアログ ボックス上部の [ヘルプ] アイコン をクリックし、オプションをクリックします。

関連項目

  • ログ ファイルのデフォルト ディレクトリを指定する


[レポート ドキュメント ファイル フォルダの選択] ダイアログ ボックス

このダイアログ ボックスを使用して、レポートの生成によって作成されるレポート文書ファイルを格納するフォルダを検索および選択します。デフォルトでは、ファイルは C:\Program Files\Microsoft Site Server Express\Data\Reports\Usage に格納されます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • デフォルトの保存先フォルダを選択する


[レポート定義ファイル フォルダの選択] ダイアログ ボックス

このダイアログ ボックスを使用して、作成したレポート定義ファイル (.mfa ファイル) を格納するフォルダを検索および選択します。レポート定義ファイルは、レポートの構造と内容を定義したファイルで、レポートの生成に使用されます。デフォルトでは、ファイルは C:\Program Files\Microsoft Site Server Express\Data\Analysis\Catalog\Custom に格納されます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • デフォルトの保存先フォルダを選択する


[計算キャッシュ フォルダの選択] ダイアログ ボックス

このダイアログ ボックスを使用して、計算キャッシュ ファイルを格納するフォルダを検索および選択します。計算をキャッシュすると、計算結果はすべて、指定したフォルダ内のファイルに格納されます。このファイルは、同じ計算を含むすべてのレポートで使用されます。これによって、レポートの実行時間を短縮できます。デフォルトでは、ファイルは C:\Program Files\Microsoft Site Server Express\Data\Analysis\Cache に格納されます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。


[一時作業ディレクトリの選択] ダイアログ ボックス

このダイアログ ボックスを使用して、データベースの最適化操作のための一時作業ディレクトリを検索および選択します。このダイアログ ボックスが表示されたときは、データベースの置かれたドライブに、データベースの最適化機能がテンポラリ ファイルを作成するだけのディスク領域が空いていません。別のドライブにディレクトリを指定する必要があります。データベースの最適化機能は指定されたディレクトリにテンポラリ ファイルを作成し、データベースを最適化します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • Microsoft Access データベースを圧縮する


[ログ データ ソース プロパティ] ダイアログ ボックス

このダイアログ ボックスを使用して、ログ データ ソースにインポートするログ ファイルの形式を選択します。デフォルトでは [自動検出] が選択されており、インポート実行前にログ ファイル形式が Usage Import によって自動的に検出されます。インポート時にログ ファイル形式が検出できない場合は、手動でログ ファイル形式を選択するように求めるエラー メッセージが表示されます。

Usage Import は、最初のログ データ ソースを自動的に設定します。

注

Microsoft® Open Database Connectivity (ODBC) データベースからインポートする場合は、必ず [自動検出] を選択します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • ログ データ ソースを追加する
  • ログ ファイルをインポートする
  • ログ ファイル形式のリファレンス ガイド


[サーバー プロパティ] ダイアログ ボックス

このダイアログ ボックスを使用して、サーバーに関連付けられたログ データが正常にインポートできるように、サーバーを構成します。

[サーバーの種類] ボックスの一覧で、該当するサーバーの種類を選択します。

ディレクトリが要求されたとき (つまり要求の最後が "/" のとき) にサーバーが返すファイル名を、[ディレクトリ インデックス ファイル] ボックスに入力します。ディレクトリ インデックス ファイルが複数ある場合は、そのファイル名をすべて入力します。スペースを含むファイル名 (My File.txt など) は、"" で囲みます。各ファイル名は、空白で区切り、「"file 1.htm" "file 1.asp"」のように入力します。

同じログ ファイルにログを収集するマルチ ホームのサーバーを区別したり、ホストを除外するためのデフォルトを指定するには、[IP アドレス] ボックスと [IP ポート] ボックスを使用します。

[ローカル タイムゾーン] ボックスの一覧で、コンテンツのホストとなっているサーバー コンピュータのタイム ゾーンを選択します。[ローカル ドメイン] ボックスでは、コンテンツのホストとなっているハードウェアの、ローカル ネットワークで使用されるドメイン名を入力します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • サーバーの追加および設定
  • ログ ファイルをインポートする


[サイト プロパティ] ダイアログ ボックスの [基本設定] タブ

このタブを使用して、サイトのホーム ページ URL を指定します。[サイトの URL パスの拡張子] ボックスは、同じサーバーに複数のサイトを編成する場合に指定します。

[ホームページ URL] ボックスに、サイトのホーム ページ URL を、「www.microsoft.com」と入力します。サイトにホーム ページ URL が複数あれば、それぞれの URL を "" で囲んで空白で区切り、「"www.microsoft.com" "microsoft.com"」と入力します。

注

[ホーム ページ URL (必須)] ボックスで1 つまたは複数の URL を指定するときに、明示的にプロトコルを指定しなかった場合は、Usage import によって URL に "http://" が付加されます。https を使う場合は、URL アドレスの先頭に「https://」と入力する必要があります (https://www.microsoft.com など)。

特定のディレクトリへの要求をインポートするには、コンテンツのパスを [サイトの URL パスの拡張子 (オプション)] ボックスに指定します。パスは、「/thissite/*」という形式で指定します。コンテンツがいくつかのパスに分散している場合は、それぞれのファイル名を "" で囲んで空白で区切り、「"/filepath1/*" "/filepath2/*"」のように入力します。サーバーに設定するサイトが 1 つだけの場合や、複数のサイトをセットアップしても、設定中のサイトをデフォルトのサイトにする場合は、[サイトの URL パスの拡張子 (オプション)] ボックスを空にしておきます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • サイトを追加する
  • ログ ファイルをインポートする


[サイト プロパティ] ダイアログ ボックスの [除外] タブ

このタブを使用してインポートから要求を除外します。要求は、通常、特定のホストに関連付けられています。たとえば、社員からの要求や、ソフトウェアのテストで行った要求などをインポートから除外できます。また、インライン イメージなど、特定のファイル形式への要求を除外することもできます。

[除外するホスト] ボックスに、除外する要求に関連付けられた IP アドレスとドメイン名を入力します。それぞれを "" で囲んで空白で区切り、「"*.microsoft.com" "10.86.22.*"」と入力します。

[除外するファイルの種類] ボックスに、インポートから除外するファイル拡張子を入力します。スペースを含むファイル名やファイルの種類の名前 (My file.txt など) は、"" で囲みます。複数のファイル名やファイルの種類の名前を指定する場合は、空白で区切ります (たとえば、".mfa" ".mft")。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • データをインポート対象から除外する
  • サイトを追加する


[テーブル プロパティ] ダイアログ ボックスの [デザイン] タブ

このタブを使用して、テーブルの表示形式を変更します。テーブルは、レポートのタイトルの下に表示され、実際のディメンジョンとメジャーに応じて、行および列のディメンジョン タイトルも含めることができます。

テーブルの列ディメンジョン タイトルの表示形式を変更するには、タブの右上部分にある [列ディメンジョン タイトル] をクリックします。列ディメンジョン タイトルをレポートに含める場合は、[テーブルのセルのプロパティ] の [可視] を選択し、[色] で背景色を選択します。レポートの列ディメンジョン タイトルの周囲にグリッドラインを表示する場合は、[テーブルのグリッドライン] の [可視] を選択します。[テキストのプロパティ] では、列ディメンジョン タイトルのフォントの種類、サイズ、および色を設定できます。

テキストのプロパティやテーブル セルのプロパティ、または行ディメンジョン タイトル、メジャー タイトル、列ディメンジョンのグリッドラインなども設定できます。これらを設定するには、タブの上部にあるオプションをクリックし、タブの下部で、その要素のプロパティを設定します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • テーブルを編集する


[テーブル プロパティ] ダイアログ ボックスの [詳細] タブ

このタブを使用して、[タイトル] ディメンジョンをテーブルに使用する場合の表示方法、メジャーを行と列のどちらに表示するか、および表示する最大行数と最大列数を指定します。

HTML タイトル検索を実行しても、ドキュメント タイトルが見つからなかった場合は、[タイトルまたはタイトルが利用不可の場合ファイル名を表示] をクリックします。このオプションは、ファイル名がテーブルに表示されるようにします。

HTML タイトル検索を実行し、ドキュメント タイトルとファイル名をテーブルに表示する場合は、[タイトルおよびファイル名の両方を表示] をクリックします。

デフォルトでは、テーブルには最大で 500 行と 50 カラムを含めることができます。設定を変更するには、タブの下部にある [制限] に数値を入力します。たとえば、テーブルの行数を 500 から 1,000 に変更するには、[テーブルの行の最大数] の [500] を選択し、「1000」と入力します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • テーブルを編集する


[タスクのプロパティ] の [ログ ファイル インポート] ダイアログ ボックス

このダイアログ ボックスを使用して、インポートするログ ファイルまたは Microsoft® オープン データベース コネクティビティ (ODBC) のログ テーブルを指定します。

ダイアログ ボックス上部に、データをインポートするログ ファイルまたはログ テーブルが表示されます。この一覧に追加するには、[ログ データ ソース] ボックスと [アクセス] ボックスで、種類とログのパスを入力します。

ログのアクセスの種類に [file://] を入力した場合は、[参照] をクリックしてログ ファイルが格納されているディレクトリを探し、インポートするログ ファイルを選択します。ログのアクセスの種類に [ftp://] を選択した場合は、[ログイン] をクリックして、FTP 接続のログイン情報を入力し、インポートするログ ファイルを指定します。ログのアクセスの種類に [ODBC] を選択した場合は、[ログイン] をクリックして、ODBC データベースのログイン情報を入力し、インポートするログ テーブルを指定します。

[ログ パス] ボックスに、選択したログ ファイルかログ テーブルが表示されます。ログ ファイル名かログ テーブル名の一部に日付変数として使用できます。利用できる変数の一覧については、「日付変数を使用する」を参照してください。たとえば、ログ ファイル名が mysite[date].log ([date] は yymmdd 形式の日付) なら、前日のログ ファイルをインポートするには、「mysite$1.log」と入力します。

[一覧に追加する] をクリックすると、ダイアログ ボックス上部に、指定したログ パスが追加されます。確認して [OK] をクリックします。

ログ ファイルを一覧から削除するには、削除するインポートを含む行の横の、淡色表示されているセルをクリックし、[削除] をクリックします。

注

インポート後に IP 解決、Whois 検索、および HTML タイトル検索が自動実行されるように Usage Import を設定してある場合は、これらのタスクを追加する必要はありません。ただし、1 つのジョブで複数のインポートを実行するようにスケジュールする場合は、IP 解決、Whois 検索、および HTML タイトル検索を自動実行せずに、タスクとして追加することをお勧めします。これらのタスクは、ログ ファイルをインポートするタスクの後で実行してください。IP 解決、Whois 検索、および HTML タイトル検索を何回も実行すると、ジョブの実行時間が長くなります。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • ログ ファイルをインポートする
  • ODBC データベースからインポートする
  • FTP サーバーからログ ファイルをインポートするには
  • ジョブをスケジュールする
  • ジョブにタスクを追加する


[タスクのプロパティ] の [IP アドレスの解決] ダイアログ ボックス

このダイアログ ボックスを使用して、IP アドレス解決タスクを選択します。IP 解決タスクは、IP アドレスからドメイン名を求め、データベースに格納するタスクです。たとえば、198.105.232.4 という IP アドレスからは、microsoft.com というドメイン名が得られます。

注

インポート後に IP 解決、Whois 検索、および HTML タイトル検索が自動実行されるように Usage Import を設定してある場合は、これらのタスクをジョブに追加する必要はありません。ただし、1 つのジョブで複数のインポートを実行するようにスケジュールする場合は、IP 解決、Whois 検索、および HTML タイトル検索を自動実行せずに、タスクとして追加することをお勧めします。これらのタスクは、ログ ファイルをインポートするタスクの後で実行してください。IP 解決、Whois 検索、および HTML タイトル検索を何回も実行すると、ジョブの実行時間が長くなります。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • データベース中のデータの品質を高める
  • ジョブをスケジュールする
  • ジョブにタスクを追加する


[タスクのプロパティ] の [Whois 検索を実行する] ダイアログ ボックス

このダイアログ ボックスを使用して、Whois 検索実行タスクを選択します。Whois 検索実行タスクは、データベースに登録されているドメイン名を解釈し、組織名、国、州 (都道府県)、郵便番号、地域を判断するタスクです。

注

Whois 検索の前に、IP アドレスの解決タスクを実行してください。Whois 検索は、IP 解決が返す情報を使用します。ジョブのタスク実行順序を調べて、IP アドレスの解決タスクが Whois 検索タスクの前にあることを確認してください。

インポート後に IP 解決、Whois 検索、および HTML タイトル検索が自動実行されるように Usage Import を設定してある場合は、これらのタスクをジョブに追加する必要はありません。ただし、1 つのジョブで複数のインポートを実行するようにスケジュールする場合は、IP 解決、Whois 検索、および HTML タイトル検索を自動実行せずに、タスクとして追加することをお勧めします。これらのタスクは、ログ ファイルをインポートするタスクの後で実行してください。IP 解決、Whois 検索、および HTML タイトル検索を何回も実行すると、ジョブの実行時間が長くなります。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • インターネットに接続する
  • データベース中のデータの品質を高める
  • アクティビティのスケジュール
  • ジョブをスケジュールする
  • ジョブにタスクを追加する


[タスクのプロパティ] の [HTML タイトル検索の実行] ダイアログ ボックス

このダイアログ ボックスを使用して、タイトルを検索するファイルを指定します。HTML タイトル検索は、指定したフィルタと一致するファイルをデータベースから検索し、そのファイルに関連付けられたドキュメント タイトルを取得するタスクです。HTML タイトル検索を実行し、単なるファイル名ではなくドキュメント タイトルを入れることによって、レポートを分かりやすくできます。

フィルタを指定して、タイトル検索するファイルを決定します。フィルタは、ディメンジョン、演算子、および値の 3 要素を、"<ディメンジョン><演算子><値>" という構文で表した式です。

HTML タイトル検索でデフォルトのフィルタ (タイトル = "") を使用すると、まだタイトルがないファイルがデータベースから検索されます。

たとえば、(ファイル名 = /ourproducts/*) というフィルタは、"ファイル名" ディメンジョン、= 演算子、および /ourproducts/* という値を表します。このフィルタを使って HTML タイトル検索すると、データベースから、/ourproducts/* というパスに関連付けられたファイルが検索されます。

フィルタを追加するには、[ディメンジョン] ボックスを選択し、[条件] ボックスの一覧から適切な値を選択し、[値] ボックスで値を入力します。式を確認して [追加] をクリックします。式を and や or で区切って並べると、複雑なフィルタも作成できます。たとえば、サイトの /gifts と /apparel に関連付けられたファイルについてタイトル検索を実行するには、(ファイル名 = /gifts/*) OR (ファイル名 = /apparel/*) というフィルタを使用します。

フィルタをすべて入力し、[OK] をクリックします。

注

プロキシ サーバーを使用する場合は、HTML タイトル検索を実行する前に、HTTP プロキシ サーバー アドレスとポート番号を指定する必要があります。

インポート後に IP 解決、Whois 検索、および HTML タイトル検索が自動実行されるように設定してある場合は、ジョブにこれらのタスクを追加する必要はありません。ただし、1 つのジョブで複数のインポートを実行するようにスケジュールする場合は、IP 解決、Whois 検索、および HTML タイトル検索を自動実行せずに、タスクとして追加することをお勧めします。これらのタスクは、ログ ファイルをインポートするタスクの後で実行してください。IP 解決、Whois 検索、および HTML タイトル検索を何回も実行すると、ジョブの実行時間が長くなります。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • データベース中のデータの品質を高める
  • フィルタについて
  • ジョブをスケジュールする
  • ジョブにタスクを追加する


[タスクのプロパティ] の [レポートの実行] ダイアログ ボックス

このダイアログ ボックスを使用して、レポートの生成に使うレポート定義ファイル (.mfa) と、レポートを書き込むファイル名を指定します。

レポートを毎回別のファイルに作成するには、[ドキュメント ファイル] ボックスで日付変数を使用します。利用できる変数の一覧については、「日付変数を使用する」を参照してください。たとえば、bandwidth[date].html ([date] は、日を 1 桁の場合は頭に 0 を付ける形式で表したもの) というファイルにレポートを書き込むには、[ドキュメント ファイル] ボックスに「bandwidth$d.html」と入力します。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • レポートを実行するには
  • ジョブをスケジュールする
  • ジョブにタスクを追加する


[タスクのプロパティ] の [要求の削除タスク] ダイアログ ボックス

このダイアログ ボックスを使用して、削除する要求を限定するフィルタを指定します。このタスクを実行すると、指定したフィルタと一致する要求が、データベースから削除されます。

フィルタは、ディメンジョン、演算子、および値の 3 要素を、"<ディメンジョン><演算子><値>" という構文で表した式です。たとえば、(日付 = 98/07/14) というフィルタは、"日付" ディメンジョン、= 演算子、および 98/07/14 という値を表します。

フィルタを追加するには、[ディメンジョン] ボックスを選択し、[条件] ボックスの一覧から適切な値を選択し、[値] ボックスで値を入力します。式を確認して [追加] をクリックします。式を and や or で区切って並べると、複雑なフィルタも作成できます。たとえば、1998 年 7 月の 4 日 から 8 日までに発生した要求を削除するには、(日付 >= 98/07/04) AND (日付 <= 98/07/08) というフィルタを使用します。

注

削除したデータを復元するには、Usage Import を使用してインポートしたデータをすべて削除し、データをもう一度インポートしてください。

特定オプションのヘルプを表示するには、 [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • 要求を削除するには
  • フィルタについて
  • インポート済みのログ ファイルを管理する
  • ジョブにタスクを追加する
  • ジョブをスケジュールする


[タスクのプロパティ] の [データベース最適化] ダイアログ ボックス

このダイアログ ボックスを使用して、Microsoft® Access データベースを圧縮するタスクを選択します。データベースの圧縮を定期的に行い、データベースが大きくなり過ぎないようにすることによって、最適なパフォーマンスが維持できます。

特定オプションのヘルプを表示するには、 [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • Microsoft Access データベースを圧縮する
  • ジョブにタスクを追加する
  • ジョブをスケジュールする


[HTML タイトルの検索] ダイアログ ボックス

このダイアログ ボックスを使用して、タイトル検索するファイルを指定します。HTML タイトル検索は、指定したフィルタを満たすファイルをデータベースから検索し、関連付けられたドキュメント タイトルを取得するタスクです。HTML タイトル検索を実行し、単なるファイル名ではなくドキュメント タイトルを入れることによって、レポートを分かりやすくできます。

フィルタを指定し、タイトル検索するファイルを決定します。フィルタは、ディメンジョン、演算子、および値の 3 要素を、"<ディメンジョン><演算子><値>" という構文で表した式です。たとえば、(ファイル名 = /ourproducts/*) というフィルタは、"ファイル名" ディメンジョン、= 演算子、および /ourproducts/* という値を表します。このフィルタを使用すると、データベースから、パス /ourproducts/ に関連付けられたファイルが検索されます。

HTML タイトル検索でデフォルトのフィルタ (タイトル = "") を使用すると、タイトルの値がないファイルがデータベースから検索されます。

フィルタを追加するには、[ディメンジョン] ボックスを選択し、 [条件] ボックスの一覧から適切な値を選択し、[値] ボックスで値を入力します。式を確認して [追加] をクリックします。式を and や or で区切って並べると、複雑なフィルタも作成できます。たとえば、サイトのうち、/gifts と /apparel に関連付けられたファイルについてタイトル検索を実行するには、(ファイル名 = /gifts/*) OR (ファイル名 = /apparel/*) というフィルタを使用します。

フィルタの指定を済ませたら、[検索] をクリックします。

重要

プロキシ サーバーを使用する場合は、HTML タイトル検索を実行する前に、HTTP プロキシ サーバー アドレスとポート番号を指定する必要があります。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • データベース中のデータの品質を高める


[Report Writer] ダイアログ ボックス

レポートを生成したり、既存のレポート定義を開いたりするときに、このダイアログ ボックスを使用して、Report Writer のカタログを開くかどうかを指定します。

標準のレポート定義は、すべて [Report Writer カタログ] フォルダに入っています。[Report Writer カタログ] をクリックした場合は、フォルダからレポート定義を選択します。ここでレポートを生成したり、レポートを生成する前に変更したり、分析する要求を限定することもできます。

[既存のレポート定義を開く] をクリックすると、選択したレポート定義が変更できます。レポートの生成もできます。

特定のオプションに関するヘルプを表示するには、ダイアログ ボックスの右上の [ヘルプ] アイコン をクリックし、そのオプションをクリックします。

関連項目

  • Report Writer カタログからレポートを実行する